Gizmo rendering visible edges

I wanted to make a gizmo for my add-on and I prefer it to be relatively large. Unfortunately, I’m noticing very clear edges of triangles in the rendering of the gizmo. Is there anything I can do to improve this, or is this how gizmos render at the moment? Maybe this hasn’t been noticed or hasn’t been an issue because the blender native gizmos are rather thin and spindly.


Hi, I’m not entirely sure what’s causing that, but it looks similar to a problem in this question:

Maybe try disabling GL_BLEND and GL_POLYGON_SMOOTH?

Since I think that would disable anti-aliasing, I don’t think it’s an acceptable solution.

For sure it would be good to find out if that’s what’s causing the edges to appear, but I don’t know how to disable GL_BLEND and GL_POLYGON_SMOOTH for gizmos. I know it’s not necessary to import bgl to write a gizmo script.