Git branch blender-v2.83-release gives the latest BETA, how to get the latest RELEASE?

Trying to build 2.83.6 release, but I can only get 2.83.7 beta, because that is what git checkout for the 2.83 release branch will give me.

I tried grabbing this

And throwing all of that into the git of 2.83.7 beta folder. It builds and runs, but there’s issues with it, that I am assuming are because of this weird replacement process I’m doing.

I tried using that 2.83.6 source download, by clicking on the make.bat, but it just brings up a cmd window for a blip of a second and closes again. Nevermind that it makes me download the lib files a second time. I noticed that it checks for spaces in the file path, so I removed those so it would at least run for a bit, but now that it downloaded some or all of the lib files it just opens and instantly closes again.

I’d rather just do what I always do, checkout the release branch for whatever version. But since, in 2.83’s case, that will give me the latest beta, that isn’t an option right now.

Ok, so here’s the error, I had to record my screen to see what it’s saying before instantly closing
checking out submodules
fatal: not a git repository (or any of the parent directories): .git

Which is really just extra annoying. All I want in the first place is for git checkout for 2.83 release to actually do what it says, give me the release, not the beta.

FIX for not a git repository is git init
From here:

All official releases are tagged, so for the latest (as for now) released version you’d check out the v2.83.6.1 tag.

1 Like

Man it’s always something so simple. Thanks a lot been doing all kinds of dumb stuff trying to figure out what’s wrong, and wondering why it would be that way in the first place