Failed to locate SVN (macOS 10.15.5, Xcode 11.5)

svn: error: Failed to locate 'svn'.
svn: error: The subversion command line tools are no longer provided by Xcode.

I tried to install the Command Line Tools package by running xcode-select --install
but it didn’t help. Need something else?

Can someone update the wiki?

I had the same issue. I solved it by installing svn with homebrew.

brew install svn

If you don’t have homebrew install yet, install it by running this first.

/bin/bash -c "$(curl -fsSL"
1 Like

I’ve updated the build docs.


@jenkm if you don’t use brew (which is not a good idea though), try this
I edited the steps to add the first one since they don’t seem to be working for you. They worked for the OP here however:

  • sudo xcode-select -s /Library/Developer/CommandLineTools (to switch the path from Xcode to /Library)
  • Delete the /Library/Developer/CommandLineTools folder. (For a fresh download)
  • Run sudo xcode-select --install
  • sudo xcode-select -r (Reset the path to Xcode)
1 Like