ERROR with Blender 2.93 - Build --- Undefined symbols for architecture x86_64: (Mac OSX - Mojave)

Hello, I have had a big problem for 5 days, I can no longer build Blender 2.93. Everything is going well, then in the end here is the message I get:

[100%] Linking CXX executable …/…/bin/Blender.app/Contents/MacOS/Blender
Undefined symbols for architecture x86_64:
“_preadv”, referenced from:
_os_preadv in libpython3.9.a(posixmodule.o)
“_pwritev”, referenced from:
_os_pwritev in libpython3.9.a(posixmodule.o)
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[3]: *** [bin/Blender.app/Contents/MacOS/Blender] Error 1
make[2]: *** [source/creator/CMakeFiles/blender.dir/all] Error 2
make[1]: *** [all] Error 2
make: *** [all] Error 2

Do you have a solution ? Is the error known to the developers? Thank you for your comeback.
Thanks a lot

Please see Compiling latest branch on MacOS fails (undefined symbol)

Good evening, and thank you Ankitm,
is your “python” folder valid for all next versions of Blender? where did you get this folder, can we get it somewhere in one of the Blender.org repositories? The problem is only with this file? will this be fixed soon?
Thank you again Anktim, it works for me.

So far only for 2.93. Older and newer versions used/will use a different Python version.

I built it https://wiki.blender.org/wiki/Building_Blender/Dependencies
So no.

I don’t get it.

Yes, underway.

Hello, can you explain to me how you did, I tried with the hints from “https://wiki.blender.org/wiki/Building_Blender/Dependencies” all weekend but to no avail. On the other hand, I have a friend who is on Mac OSX BIG SUR, trying on his Mac it worked, is the error related to OSX Mojave? Thanks for your help, so I can do this on my own just in case while waiting for everything to be fixed, and i would like succeed in built this dependancies.
Good day to you !

If you can explain me step by step how to do this… :+1: :+1: :+1:

Yes, it is a problem for macOS <= 10.14.

That project is for platform maintainers and developers are not expected to build all dependencies by themselves. It is not tested on a lot of devices either.
Instead, use the python folder I shared at Compiling latest branch on MacOS fails (undefined symbol) That will be enough to fix the link error you reported.

You don’t need to build dependencies yourself. Still if you want, you may share the specific error in https://blender.chat/channel/blender-builds and I’d be able to help. Will see if any documentation needs to be changed afterwards.