Error launching Bender!

I installed Blender by following the blender wiki in my Linux. The last command I ran was “make”. Everything went right and it installed Blender 2.83 executable in blender-git>build_linux>lib. When I clicked “Blender”, I marked it as “trusted file” and then “There was an error launching the program” popped up. What do I do now.
I am using Linux Mint.
@jesterKing @stiv Please help me.

Just a guess from macOS, can you run the executable via Terminal ?

1 Like

No idea about the “trusted file” business, but Linux is case sensitive and the executable is named ‘blender’, not ‘Blender’.

As ankitm mentioned, try running blender from the command line. The ‘make’ command prints out the path when it finishes, something like
Blender successfully built, run from: $YOUR_DIR/blender-git/build_linux/bin/blender


You might try compiling an old, stable branch of Blender first, since sometimes there are build problems that need to be fixed. I don’t think that’s the case for you, though.

For example, ever since Optix support was added, I get errors when I do make release because I don’t have the Optix stuff on my system (since I can’t use it anyway).

1 Like

Yes, I got the path " /home/tsadarsh0707/blender-git/build_linux/bin/blender". I then did the following:

cd ~/blender-git/build_linux/bin

and I got the following result:

Command ‘blender’ not found, but can be installed with:
sudo apt install blender

I may sound stupid, I’m really new to Linux, but is this the way to ‘run’ from command line?

Command blender should be ./blender


thank you so much. it works now. what does the “./” specify?

The ./ notation is useful when trying to run a script or other executable in the current directory. Unlike the Windows command prompt, Unix (and Unix-like systems like Linux) shells do not check the current directory for executables before checking the PATH environment variable, and Unix systems tend not to include ./ in the PATH for security reasons.


IMO compiling Blender is a lot harder on Linux (I can build it but it’s always broken somehow). If you want to develop and you have Windows you should try it out on Windows, since LazyDodo is always around to fix the make command and provide help for that. I don’t think there’s anyone doing that for Linux.

Also, I’ve been using Ubuntu for about 6 months and I had no idea what I was doing the whole time… I recommend learning as much as you can about Linux and Bash, too. It seems like I’m always running into issues that need console commands to fix or query or even just to access. Using the terminal isn’t optional in Linux.

1 Like

heh, thanks for the kind words


Thanks for helping me build Blender!