Error during `make install`


#1

This is the second time I’ve stumbled upon this issue. First time I’ve managed to solve it, but now I’m powerless.

now run: "make install" to copy runtime files and scripts to 2.80
[100%] Built target blender
  executing: /home/xxx/blender-git/build_linux_full/bin/blender --help
/home/xxx/blender-git/build_linux_full/bin/blender: symbol lookup error: /home/xxx/blender-git/build_linux_full/bin/blender: undefined symbol: _ZTIN7Alembic3Abc3v107OObjectE
Traceback (most recent call last):
  File "/home/xxx/blender-git/blender/doc/manpage/blender.1.py", line 55, in <module>
    blender_help = subprocess.check_output(cmd).decode(encoding="utf-8")
  File "/usr/lib/python3.7/subprocess.py", line 389, in check_output
    **kwargs).stdout
  File "/usr/lib/python3.7/subprocess.py", line 481, in run
    output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command '['/home/xxx/blender-git/build_linux_full/bin/blender', '--help']' returned non-zero exit status 127.
make[3]: *** [source/creator/CMakeFiles/blender_man_page.dir/build.make:57: source/creator/CMakeFiles/blender_man_page] Error 1
make[2]: *** [CMakeFiles/Makefile2:7652: source/creator/CMakeFiles/blender_man_page.dir/all] Error 2
make[1]: *** [Makefile:163: all] Error 2
make: *** [GNUmakefile:149: all] Error 2

I’m on antergos (arch) current release. I’m not sure but last update that had something connected to Blender building was probably Python up to 3.7.1-1 and this error looks like this could be the case.


#2

This seems to be a linking error related to Alembic, but I’ve never seen this error before. It’s hard to say what could be causing that, it depends on how you compiled the Alembic library and how it was linked to Blender. Did you follow the standard install_deps.sh or make deps steps?

Doing a clean build is always a thing to try as well.

Disabling WITH_DOC_MANPAGE in CMake will probably get you past this specific error, but probably Blender will still fail to run afterwards anyway.


#3

Of course I’ve tried with clean install :wink: Sorry I didn’t mentioned it, too obvious :wink: Sadly it wasn’t helpful. I’ve alembic package from install_deps and it’s in arch repo so now I have alembic 1.7.9-1 version it’s build date is from 29 September. I’m building junkie so if nothing was updated here it should be ok.

make deps gives me this error:

-- Installing: /home/xxx/blender-git/build_linux/deps/Release/sdl/share/aclocal/sdl2.m4 [ 34%] Completed 'external_sdl' [ 34%] Built target external_sdl make[1]: *** [Makefile:130: all] Error 2 make: *** [GNUmakefile:182: deps] Error 2

Building with make is ok, make full produce this error.

I’ve tried to disable WITH_ALEMBIC and WITH_DOC_MANPAGE but the error is still the same.

I was also reinstalling nvidia drivers (and CUDA toolkit) before this error, but I’m not sure how this could affect it.


#4

It’s odd that disabling Alembic does not solve the issue. It’s unclear to me where there could be Alembic code remaining to throw that error.

You could try running install_deps.sh with --force-alembic to build Alembic rather than using the package, maybe it helps.

The error seems to be the same as this one, which was solved on the Arch side. But I can’t find what the solution was:
https://bugs.archlinux.org/task/53728


#5

It’s solved.

I’ve removed Alembic 1.7.9 from my packages, also Blender 2.79b official from repository was removed as dependency. (Installing Blender again form repo bring back Alembic so hell with it. 2.8 it will be from now on :wink:

I’ve again cleaned /opt/lib as Alembic 1.7.8 was sitting there after --force-alembic.
Clean installation with install_deps.sh and everything is working again fine.

Why this happened after updating os I do not know. Some other package could mess with linking to Alembic?
It’s still a bit of a workaround as I’ve lost 2.79b from repo, but luckily it’s not an issue for me as I’m building master as well as 2.8. Just a note for the future users with this issue.