Error building Fracture branch

I get this error when trying to build the fracture branch:

Configuring Blender in “/home/cet/blender-fracture-git/build_linux_full” …
loading initial cache file /home/cet/blender-fracture-git/blender/build_files/cmake/config/blender_full.cmake
CMake Error at /usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
Could NOT find PythonLibsUnix (missing: PYTHON_LIBRARY PYTHON_LIBPATH
Call Stack (most recent call first):
/usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE)
build_files/cmake/Modules/FindPythonLibsUnix.cmake:184 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
build_files/cmake/platform/platform_unix.cmake:92 (find_package)
CMakeLists.txt:872 (include)

Would anyone willing with a little bit of time help me out a bit? :slight_smile:

Are you on linux?

If that’s the case try using the “make deps” command inside the blender-git/blender/ folder, it will try to build up your dependencies, it seems that it can’t find python, make deps could help.


hm… I tried inside the build_environment folder, and it installed a bunch of stuff including OIIO 1.7… I didn’t mention that I was already compiling 2.8 main branch as well… :slight_smile: I ended up wreaking havoc on the OIIO setup that is being used there, and can’t compile any of the other updated branches as well… Not your fault tho, i just didn’t think far enough to think that that might mess up other branches, since i thought they were all based on an updated 2.8 mainbranch…

Now my question would be, how do I get my correct OIIO back in the main branch…? I tried installing the deps for 2.8 main, but it throws me a whole bunch of errors on OIIO still… :slight_smile: