Draw, Paint & Sculpting Keymap Proposal - Feedback Request

It’s just an idea. Currently, it cannot be executed correctly since these two keyboard functions do not exist. With “Ctrl+Tab” it is an exception that works more or less well configuring it in the way that I expose in the video but for other keys it mostly creates failures. Perhaps in the future we can add these two functions and test their potential to address some complications. Thank you Julien for being so close to the community.

@JulienKaspar I am writing this here instead of making a report because I think you’ll want to adress this for 4.0.

Ctrl-Shift-LMB is Mask Lasso select gesture. But turns out Ctrl-Shift-RMB is not assigned to anything, I thought intuitively it should be demasking with lasso, but it inherits deselect gesture from object mode and deselects sculpt object, which is illogical too and can cause problem with some python scripts that work on selected_objects.

So I thought I’ll suggest CTRL-Shift-RMB as remove mask with lasso, but before I tried to assign that shortcut myself and I found either bug or very terrible design.

When you assign paint.mask_lasso_gesture and select Mode: Value Inverted, it breaks the lasso mask alltogether. At first it does what it says, it removes the masked areas, but after that when you try to use Ctrl-Shift-LMB to lasso mask, it doesn’t mask anymore, it also deselects, because somehow value was inverted not only for that single stroke, but for entire lasso mask.

Same thing happens with every option. If you set Mode to Invert on new keymap and use it, regular Ctrl-Shift-LMB also turns into Invert. If you set value to 0 it also sets value for Ctrl-Shift-LMB to 0. Only way to revert this behavior and get lasso mask to its original behavior is to select lasso mask tool and select something with it.

I suggest this to be solved and Ctrl-Shift-RMB to be assigned to paint.mask_lasso_gesture with Value: Inverted, so that you can mask and remove mask easily without having to switch to a tool. And also to avoid deselecting sculpt object with object mode shortcut.

EDIT: Now I think it would also make sense to change the shortcut and assign it to Ctrl-RMB for masking, and Shift-Ctrl-RMB for demasking, to match every other mode, where it does lasso select and deselect. It would unify the shortcut for entire 3D view

Have you tested this in Blender 4.0? This is already fixed.
Check out the release notes to read up on the current shortcut changes:

In the official keymap the mode “Invert” isn’t used because it inverts the areas within the drawn gesture. Instead the value is either set to 1 or 0.

I was testing in 4.0 but it is indeed fixed in latest build. It’s quite weird tho that in other modes Ctrl-RMB selects, and in sculpt mode it demasks. On technical level it is correct, but feels weird using it in practice so I switched them for me. Thanks

1 Like