Cycles - Viewport Render Image

Viewport Render Image operator doesn’t work for Cycles’s Rendered shading mode.
Clearly mentioned in Blender’s Manual, but completely confusing when you try render in Blender.

There is not a single indicator what is going on here.
Even for me as experienced user I was hunting some version/GPU issue until I started to search in manual. (I came up to this issue via this Q thread.)

Would be really helpful to disable this

  • like nothing happens by choosing it from menu + visible warning text at bottom row with description what is wrong here
  • or grey it out in View menu (including Quick Favorites) to prevent access when Rendered shading is selected

Thank you make our lives better :slight_smile:


I agree- if an operator only works with Eevee and Workbench, not Cycles, that operator shouldn’t be usable in Cycles. This is a common pattern across Blender; for example, Bake operators aren’t available while using Eevee