Cycles Building CUDA on Ubuntu 19.10 - No supported gcc/g++ host compiler found

I’m trying to build Blender with Cycles CUDA binaries but get the following error. My suspicion is that CUDA does not like the GCC version that ships with Ubuntu 19.10 (9.2.1). I tried to mitigate that by setting CUDA_HOST_COMPILER to /usr/bin/gcc-8 in cmake but that throws the same error. I think that is because CUDA wants 8.2.0 and I have 8.3.0 installed?

How can I set clang as a compiler?

[ 11%] Generating filter_sm_30.cubin
ERROR: No supported gcc/g++ host compiler found, but clang-8 is available.
Use ‘nvcc -ccbin clang-8’ to use that instead.
make[2]: *** [intern/cycles/kernel/CMakeFiles/cycles_kernel_cuda.dir/build.make:174: intern/cycles/kernel/filter_sm_30.cubin] Error 1
make[1]: *** [CMakeFiles/Makefile2:1416: intern/cycles/kernel/CMakeFiles/cycles_kernel_cuda.dir/all] Error 2
make: *** [Makefile:163: all] Error 2

“Fixed” it by manually editing the generated makefiles but that is something I would have to re-do every time I re-configure cmake :frowning: