Compiling blender-2.82a in aarch64

Hi everyone,

I tried to build the latest blender in an ARM machine with Centos 7.6.1810 (aarch64). I ran BUILD_NOTE.txt that created by [], and it gave “manually specified variables were not used by the project” (those variables are blender’s dependecies, e.g. llvm, etc). However, those variables were already installed by [], and BUILD_NOTE used -D to link them to avoid reinstallation by cmake, but I don’t know why cmake cannot find those variables.

For example, the variable such as ALEMBIC has already been installed via [], so cmake just tried to link its root_dir, but I don’t know why it warned me that the variable ALEMBIC_ROOT_DIR is not used by the project. Thanks for any help in advance!

There’s two issues here:

  • For building Blender, cmake should be pointed at the blender/ top level directory, not blender/build_files/build_environment/
  • The build folder should be somewhere outside the blender/ source code directory, typically a build_linux/ folder right next to it.

It’s hard to tell which commands you ran to get into this situation.

Problem has been solved successfully, thank you very much!!! do appreciated!!