Clicking "Through" Gizmo

The new Industry Compatible keymap let’s you select an object behind/being blocked by the gizmo when you release the mouse. This is great, I’m really happy about it.

When you switch over to the Blender keymap the behavior is no longer present.

I’m trying to figure out where and how in the keymap this behavior is being enabled/disabled. Does anyone know how it works?


If you go to Preferences > Keymap, you’ll see a preference option called Activate Gizmo. Set it to Drag.

Honestly I thought we made this the default for exactly the reason that otherwise gizmos will always block input.

I would like to add playing with the mouse drag option under input

Active Gizmo -> Drag is better solution, but still not so better…
Because in this way we can just click to select the object (even under the gizmo) & we have to click & drag (even to some value) to activate the gizmo, that’s is why it’s is not so expected behavior.
I mean, for example if you are working with very minor (perfect) details often on activating the gizmo by clicking the gizmo (without any motion) you press the shift key to move very slowly… If this option is on you have to click & drag (to activate the gizmo) in this way you already transform too much then you can press shift
So, i think better solutions is to hide the gizmo when holding down some key (e.g. Alt or Mouse button 5) and when button released show the gizmo automatically. when the gizmo is hidden you can easily select the mesh you want another benefit, you can easily underlying objects…
to achieve this & more info see the post:

1 Like

Right. One of the ways other apps deal with this is simply to make it easier to quickly hide the gizmo.

a big button / shortcut, to switch between active and modal mode :slight_smile:

1 Like