Change branch (master to 283 release) cause svn errors (windows 10)

Recently I often see same errors about svn when I change branch in local, by git checkout “branch name” >> make update.

  1. change branch master to “blender-v2.83-release” by git checkout blender-v2.83-release

  2. make update

I get these svn error.

svn: E155009: Failed to run the WC DB work queue associated with ‘C:\myprograms\blender-git\lib\win64_vc15\python\37\lib\ensurepip_bundled’, work item 27565 (file-install python/37/DLLs/_bz2.pyd 1 0 1 1)
svn: E720005: Can’t move ‘C:\myprograms\blender-git\lib\win64_vc15.svn\tmp\svn-4758AC31’ to ‘C:\myprograms\blender-git\lib\win64_vc15\python\37\DLLs_bz2.pyd’: (access denied)
C:\Program Files\TortoiseSVN\bin\svn.exe --non-interactive update C:/myprograms/blender-git/blender…\lib\win64_vc15
svn: E155037: Previous operation has not finished; run ‘cleanup’ if it was interrupted

I saw same error when I changed branch to master and try to update (make update).
At that time, I could clean up (SVN) the directory, after remove python directory in lib, then i
I could “make update”. then could build blender 2.90 (current master)

but today I tried to up-date blender283, then saw same error, but
same procedure not work for me.(clean up svn)

I had exactly the same issue yesterday.

It took me several hours to finally be able to build 2.83 branch. What worked for me was cleaning up SVN repo of the libraries several times.

I know it sounds strange, but every time error popped up, I closed make terminal, went to the lib\win64_vc15 directory, initiated Cleanup command from Tortoise SVN. and ran make again. It took like 5 repetitions, but then finally make succeeded.

That being said, there must be something wrong with the SVN repo here. It’s especially frustrating for first timers trying to build Blender, as you will encounter multiple failures along the way despite following the guide exactly.

Yes I experienced same issue, then could solve use “svn clean up”
for lib\win64_vc15 ,then worked before…

But same procedure seems not work this time (master>>blender273) :thinking:
svn clean up succeed, but after all when I make update, I got those erroer.
I suspect, if I once exit command prompt etc, but I do not know.

At current I delete, lib directory, and try to re-download lib again.
(but If It should happen when I change branch, it is really annoying for me,)

I serched about those svn errors with google,then found this topics,
svn error

, but the procedure seems too complex for me (I do not know well about svn) :sweat_smile:

I’ve had those issues even if I completely deleted the lib folder and executed make update again. Therefore it doesn’t seem to be dependent on if you ever exit terminal while performing make update or not. I suspect it may have something to do with the compatibility of file names or file path names on windows vs linux.

Thanks your reply. As you said, I tried to delete lib then checkout again,
but it still not work (though I do not know, why it worked before)

Then I change tortoice svn “clean up” options, (activate) all option ,without expect much, then, clean up>> make update.

finally it seems worked for me,…but I can not be sure,if it work next time…

Best to use completely separate folders for 2.83 and master, with their own libraries folder. Switching back and forth between them is going to be very slow to download all the libraries every time.

The subversion server is being unreliable with lots of big files and many users accessing them. We we would like to change it so something else, but for now we don’t have an easy solution besides doing cleanup and trying again.