Can't sign in to blender.chat anymore

I fill in my mail adress and password, then this appears and keeps coming up, no matter what i do:


Was i nasty ?:slight_smile:
Linux Mint 19 and firefox with all updates.

I’m having the same issue on Windows 10 + Chrome.

One thing that comes to mind is I recently enabled two-factor authentication, but all I get is an email with a 6-digit code, and not sure where to enter it.

@LazyDodo Would you happen to know a solution? (Or who to contact about this, sorry wasn’t sure)

@fsiddi mind taking this one?

Another issue I’ve noticed – maybe related:
If you get logged out of devtalk and try to log back in with the wrong
email because you’ve forgot which one you registered with, it forces
you to create a new account with that wrong email. There’s no way I
can see to back out and make it forget the wrong email address so you
can log in with the correct one. Instead, you’re forced to log in with a
different browser to work around it.

Login management is done via Blender ID. Make sure you are logged out on Blender ID before logging in to Blender Chat again with a different account.

Not sure how you are inserting your username and password there. The only way to log in would be via Blender ID. Could you share the url you visit to log in?

From blender.chat I click on the “Sign in to start talking” button and it takes me to the image posted above (still on the blender.chat/home url).

Once I click on the “Login with Blender ID” button, it takes me to the Blender ID login page (Sign in to Blender ID - Blender ID - blender.org), where I sign in with email and password.

However, after that, it takes me back again to the screen above at blender.chat/home and clicking the “Login with Blender ID” button does nothing except send an authentication code to my email which only contains:

Here is your authentication code:
XXX-XXX
Do not provide this code to anyone.
If you didn’t try to login in your account please ignore this email.

Ok, it looks like you enable 2FA for email and password authentication, and Rocket Chat tries to enforce that for OAuth-based logins. I have to check if that’s solved in the latest version of Rocket Chat. In the meantime you can disable 2FA by going to the login page:

  • right-click inspect the login form
  • look for the “fields” div and disable the display: none property
  • login with your username and password
  • update the 2FA settings

image

3 Likes

Thanks a lot! That worked for me.

Just wanted to say that I had the same issue and that this, indeed, has solved it for me.


There ain’t no div class fields, only div class tooltip:
Please consider being more verbose with your instructions. You can’t imagine how stupid i am. Imagine me being your grandma. Speek slowly, make full sentences and doN#t take anything for granted.
Thx :wink:

I also had the same issue and scratched my mind almost for two days :sweat_smile:.