Cannot get blender download and build to run

Greetings.

Having tried out the latest blender 2.92 alpha version and seen the experimental point cloud object, I decided to download and build the latest version and all the associated dependencies (as per the build instructions on the Blender developers page) today from git hub so as to have look at the code pertaining to the point cloud object. No problems or errors with the building, but upon attempting to run the resultant build I get a window with the error displayed in a pop up window

Program ‘blender.exe’ failed to run: The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail

Having never encountered this error ever before, I looked it up online since there seems to not be anything in the forums here, and according to what I found, is that a Microsoft Visual C++ Redistributable Package is missing or possibly corrupted. So I unistalled and reinsallted the 2015-2190 Microsoft Visual C++ Redistributable Package. But this did not solve the problem. I doubt that Blender is using any of the earlier versions which I do have installed.

Attempting to run blender from the console I get the same error message with the additional lines

At line:1
char:1

  • ./blender

At line:1 char:1

  • ./blender
  •   + CategoryInfo          : ResourceUnavailable: (:) [], ApplicationFailedException
      + FullyQualifiedErrorId : NativeCommandFailed
    
    

Is this an error caused by a bug, a poor build process or something else?
Should I wait a few days for a new build version to be issued and try again?

All my versions of the binary downloads 2.8 to 2.92 alpha work, so I am baffled.

And how can I find out which version of Blender has been downloaded and built, as the readme.text file has not information within it to report a bug, if that is what I have here, to indicate which version of Blender this is.

Thanks in advance.

There’s no need to build your self if all you want is the latest code, daily builds are available on https://builder.blender.org .

However judging from your description, if sounds like the INSTALL phase of the build either was not run or had issues, but you included no build logs so it is hard to say for sure.

I agree with @LazyDodo regarding the install build. I’m also new to building Blender and ran into these errors myself. The side-by-side configuration error is probably occurring because libraries are missing in the build folder. When building, the make update command pulls all the dependencies (so you should have a lib folder next to the blender folder) and the install build then includes copying the libraries to the build folder. Just check your build folder where the blender executable lives and see if there’s anything else beside it in the folder (compare to your pre-built version).

“sounds like the INSTALL phase of the build either was not run or had issues”

This was my thoughts as well. Especially after making this post, I noticed that the last build message had a skipped 3 files when building within visual studio.

The reason I am building blender is because I do have a project with a new object type and data structure that I would like to try and integrate into blender, and I am trying to find a way to do that. The cloud object may just be what I need for that purpose. So my preferred method of building blender is within Visual Studio because within Visual Studio one can view and explore the class and variable hierarchy so much easier than from the git hub files. I could not do this without downloading all the dependencies and also needed to know which version of blender I had. So, to test to see if I could build and run Blender was not a difficult decision to make if I was going to start modifying the code. I had to know that everything was in order.

As I was typing the above, I had made another update (and there seems to be a few) and a build in both visual studio 2017 and 2019. All now seems fine, and I as I expected, this is the 2.92.0 alpha version.

This problem encountered may be because I had used the command

make nobuild

and attempted to compile blender from within visual studio.

I am sure I did attempt building blender with the command

make

previously as well with the same problem. I am yet to try and rebuild blender from within visual studio again just yet.

All that remains is to evaluate if the existing experimental point cloud object can be used as a candidate for integrating my creation into blender. If it is, I will attempt to make a clone of this object, modify it and go down the deep rabbit hole that may also turn out to be too deep and beyond my capabilities and understanding of how blender is put together to do this. My previous exploration of doing this in September had me convinced I was biting off more than I could chew. It may still be the case.

Thanks for the response, and also Vaquero below as well.

Regards

from the build wiki

Once opened it’s very important the following steps are taken:

In the solution explorer find the INSTALL project, right click it and select ‘Build’ this will copy all the required files the the blender output folder. NOTE: This needs to be done atleast once for every solution configuration, ie: if you switch from Debug to Release configuration you need to redo this step.