Building fails can't update Python - Window 10

Hello, when running make update this morning I got

C:\Program Files\SlikSvn\bin\svn.exe --non-interactive cleanup D:/development/blender-git/blender…\lib\win64_vc15
svn: E155009: Failed to run the WC DB work queue associated with ‘D:\development\blender-git\lib\win64_vc15’, work item 32130 (file-remove python/37/bin/python37.dll)
svn: E720005: Can’t remove file ‘D:\development\blender-git\lib\win64_vc15\python\37\bin\python37.dll’: Access is denied.

Ran ‘svn cleanup’ and ‘svn update’ and it updated ‘lib’ to revision 62736 and updated python to 3.9 (previously 3.7)

now when I run ‘make update’ I get

D:\development\blender-git\blender>make update
No explicit msvc version requested, autodetecting version.

** Visual Studio 2019 Developer Command Prompt v16.10.0
** Copyright (c) 2021 Microsoft Corporation

[vcvarsall.bat] Environment initialized for: ‘x64’
Compiler Detection successful, detected VS2019

Python not found in external libraries, updating to latest version

Updating ‘D:\development\blender-git\lib\win64_vc15’:
At revision 62736.
python not found in lib folder

Yeah that was poor timing on my end, i should have left the python 3.7 copy a little longer, to resolve

run git pull manually once in the same folder you normally run make update in, after that make update should work as usual again.


Great, that worked. thanks!