Building Error on win

Hi there,
While trying to build Blender I m getting this error, I build it like 20 mins ago.

Thanks for your help

This is a forum to get help building Blender from source.

If you wish to report a bug, request a feature or get help using Blender, please use the links in the header instead.

I’m not very experienced with windows, but I guess you are missing the libs package.

See Building Blender/Windows - Blender Developer Wiki in the section
Download Sources and libraries… You probably still need to run ‘make update’ and let it download the precompiled libraries.

I did run make update at beginning I guest i have to do it again.

You’ll have to run make update any time there’s a change in the libs.

Now i m getting this unknown error

I m having that Error after I ran make update.

we stopped using almost a year ago, I suggest just deleting what you have and following the build instructions @Baardaap linked from scratch

Hello there,
I have deleted the old folder and I’m following the instructions from the link posted by @Baardaap and now I’m getting python not found error

Should I proceed with the instructions or do something else?
Thanks in advance

Ah yeah, i see the problem, i’ll ge that fixed, for now just re-run the command and you’ll be ok

1 Like

Thanks I got it compiled :slight_smile:

Hello, I’ve had similar error as @erickblender .
Then, I followed @Baardaap suggestion, got rid of everything and started from scratch.

First time, running
$ ./make.bat update
and I got the python error, but after running one more time it was solved.

But the main issue is when I’m trying to compile
$ ./make.bat

I was get an error

I had installed: git bash, tortoiseSVN, CMake, VSCode with ‘Desktop Development with C++’ just as recommended.

I cannot upload the Build.log as I’m a new user and the file has more than 7000 lines.
I have tried to search for answer but no success.

This post was the closest to my case… :confused:

Please attach the log file mentioned.

Somehow I cannot attach files:

I bumped your trust level, try again!

Build.txt (896.2 KB)

Let’s see…

What is the output of make showhash in your blender source folder?

This is what I get:

Everything seems up to date, i’m a bit of a loss here, beyond the strange command prompt you are using, there doesn’t seem to be anything out of place. Try building from a regular command prompt and not this ming64 thing.

Also would it be possible to attach the CMakeCache.txt from your build folder?

First of all, the CMakeCache.txt:
CMakeCache.txt (150.1 KB)

Second, when through the whole installation process again, this time also removed all compilers and code related things from my machine. I reckon there was some kind of noise between compilers versions. In addtion to the C++ Developer from Visual Studio, I had as well compilers from MSYS, I guess from the PATH, make was not getting the right compiler. All of this just to say, that I finally got it compiled! :smiley:

Thanks for the quicky replies! :slight_smile: