Build bpy succeeded on MacOSX (M1) but failed on Ubuntu 20.04

Hello everyone,

I would like to provide some feedbacks of my experience with building blender as a python module (bpy). And hopefully get some help on my failing build on Ubuntu.

First of all, I am glad to tell you that I followed instructions from Building Blender/Mac - Blender Developer Wiki, and make bpy on may M1 Mac, it worked (even with Audaspace!). I am using bpy module in my python application since 2 weeks now. :tada:

Surprisingly, when I tried doing the same thing on Ubuntu 20.04, the building process succeeded but when I did import bpy it failed with following error:

Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: ~/blender-git/lib/linux_x86_64/python/lib/python3.9/site-packages/bpy.so: undefined symbol: _ZN7Imf_2_514TypedAttributeINSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEE13readValueFromERNS_7IStreamEii

I feel that I might miss some details during my building process, can someone help me on this ?

Thanks in advance

The problem is this, do not rename the folder:

svn checkout https://svn.blender.org/svnroot/bf-blender/trunk/lib/linux_centos7_x86_64 linux_x86_64

It should just be:

svn checkout https://svn.blender.org/svnroot/bf-blender/trunk/lib/linux_centos7_x86_64

The centos7 name in the folder is used to detect that the libraries use an older C++ ABI.

Hi @brecht,

It worked after the fix of name. I should have really followed the instructions.

Thanks a lot! I fixed my gist in case someone needs it.

Have a nice day