Blender2.8 & VMware: Enabling "Accelerate 3D graphics" corrupts OpenGL font

Accelerate 3D graphics: disabled vs. enabled

I use VMware workstation 15 Pro on Win10 (GPU: AMD Vega64).
Thanks for any help.

It’s likely a bug in VMware, so you could try reporting it to them. Someone could figure out a workaround on the Blender side, though for us it’s probably not particularly high priority as far as graphics glitches go.

The first letter of words seems to draw correct most of the time (but not always), and one of the two triangles for each glyph seems to be drawn wrong. You could try setting BLF_BATCH_DRAW_LEN_MAX to 1 to see if drawing one letter at a time helps, though this will be slow.

1 Like

Thanks, it works:)

Could you give me an advice with second problem - missing fonts in nodes (outsocket)?


I’m not sure. I guess there is some specific OpenGL state that is set when drawing the output socket text, which triggers a bug in the graphics driver. Which one is hard to guess though.