Blender mantaflow not working


for some reason, whatever blender version I download and run alpha-beta or anything other mantaflow doesn’t seem to work along with whatever I set up a basic fluid liquid simulation and save then bake both data and mesh, then run timeline nothing happens and no fluid sim occurs or anything.

Here is how it is supposed to work :

  • Launch Blender from a terminal or a console.

  • Object menu -> Quick Effects -> Quick Liquid.
    Result should be : selected object has a Fluid modifier. It is used as a Flow object. A cube with wireframe display, that contains flow, is added to scene. It has a Fluid modifier. It is Domain.
    Check Both modifiers are active. Check that both objects are Liquid and not one Liquid and the other one Gas.

  • Then, select Domain, under Cache panel, cache path points to a /tmp directory. First bake is often a try. Use it as long as you are tweaking settings, When you are satisfied, for final bake ; choose a path to store simulation data.
    Check that you have the rights to create and store data files under this directory.

  • Then, under Fluid panel -> Settings subpanel -> press Bake Data button.
    When baking is finished ; you should see fluid as particles in Viewport.
    Then, activate mesh panel, press Bake Mesh button.
    When baking is finished ; you should see fluid as particles and mesh wireframe in Viewport.
    To see mesh as a surface, you have to go back to solid display.
    Then, you can bake secondary particles for Foam, Spray and Bubbles by pressing Bake Particles button under Particles panel.
    For all these baking, Result should be files into cache directory.
    If there is none, there should be an explanation in console window or terminal.

1 Like

Hi Ronan,

I have try Mantaflow quite a few time since it’s release…
For me there is some things I can’t really grasp, or maybe they doesn’t work at the moment.

For instance. I don’t know if we can regulate the flow of an inflow object.
If I have a 3/4 inch pipe with 10 PSI of pressure as an inflow object, the amount liquid coming out of the pipe will be quite different that the same 3/4 pipe with 1 PSI of pressure.

So I don’t want to reduce the size of the pipe (cube) to get less flow, but reduce the ‘‘pressure’’ of water coming out of it. Is that possible ?

A setting similar to this one in Flip Fluid addon :

Also, if I do as you said : New scene, then : ‘‘Object menu -> Quick Effects -> Quick Liquid’’ and change the viscosity preset to water/honey/oil. Bake it. Then it doesn’t change how the liquid behave.
Or maybe the viscosity is not supported at the moment ?

There is no “pressure” setting supposed to mimic real physics.
You can reduce flow by 2 manners : reducing volume of inflow or reducing its initial velocity.
I suggest to use both for a more realistic result.
You can use a disk as inflow and precise an high value for its Surface Emission under Flow source panel and decrease it to end simulation.
But mainly, you just have to animate Normal value under Initial Velocity panel.

I don’t understand why they did not consider the bug as a showstopper for 2.82 release.
Viscosity settings are working but Real World Size setting is not.

You have to scale down your simulation to fit into a domain that is 0.3 unit wide to actually obtain a simulation for a domain of 30 centimeters.
Otherwise, domain is too big to perceive a difference unless you guess how you should multiply viscosity presets to obtain correct result.
You can give insanely big values to viscosity settings, you should see a difference in a big domain.

Hi everybody, I am aware that this thread is a bit outdated, but since I have the same problem using Blender 2.93 on MacOS and Windows, I thought it might be better to tie in here than starting a whole new conversation.

I’ve been struggling with the Mantaflow fluid simulation over the past days, and it seems that it behaves somewhat erratic.

Sometimes it works out of the box, but more often than not it does not work at all or stops working after I make small changes, for no apparent reason.

I just tried again using Ronan’s description and everthings seems to be set up correctly, but the liquid just won’t flow.

I tried on different machines like MacOS and Windows, with similar results. Sometimes it works, sometimes it doesn’t, and I can’t tell why.

Does anyone else have these problems? Or do I miss something obious?

Hi Edesimon, I have the same problem, I can only get it to work 1 out of 100 times for smoke or liquid simulations, I feel like I’m missing something too, did you ever find the fix?


Hey Greg, sorry for my late reaction, I didn’t notice your reply, guess I forgot to activate the watching. I stopped trying to solve the issue, but I will have to look into this again some time in spring I guess. Did you find a solution? If not I will keep you posted if you want.