Blender Freezes Rendering Cycles in UI Mode

N.B. I am not sure this is the right place for this post - I apologise if that’s the case - this my first post here.

Blender versions >2.91.x through to 2.92 release candidate
3950X 64Gb, RTX 3070, Ubuntu (latest).

Also tried on i7 5960X, RTX 2060, W10

I have several blend files that will not, or will not reliably render anything in cycles in UI mode. The same file and settings always works perfectly in command line mode.

Note, viewport render is fine. Denoising is off for rendering, with the denoiser set up in the compositor. Bypassing that makes no difference.

I tried all cycles options, Optix, Cuda, and GPU and CPU modes. The problem is the same - it works in command line mode but not from the UI.

One initiating a render (either f11 or f12) Blender freezes at the “initialisation” point in the render window. The render can’t be stopped - Blender has to be forcibly quit.

I have tried briefly with 2.83 LTS and have yet to make a render fail there on W10, but I haven’t tested extensively.

My work around for rendering is to use command-line rendering and DJV to check render passes. But I really need UI rendering to work so that I can use Crowd Render (CR) to render my animations.

An additional point with CR, is that while the rendering is failing, Blender does not freeze. Only in standalone does the Blender freeze and have to be force quit.

For bug reports, please submit them here: