Blender 2.81 Linux - Optix Dependency

Fist time attempting to build 2.81 via Manjaro package installer from AUR

Solved CUDA dependency by installing latest CUDA, can’t solve OPTIX dependency.

PKGBUILD file offers a way to disable dependency but I’m not a coder so unfamiliar?

((DISABLE_CUDA)) && optdepends=(‘cuda: CUDA support in Cycles’) || { makedepends+=(‘cuda’) ; ((DISABLE_OPTIX)) || makedepends+=(‘optix>=7.0’); }

Here’s the contents of the whole file if helps

Someone please help me figure out how to remove Optix dependency as I don’t have an RTX card anyway.

These are not our build scripts, it’s probably best to ask the people who made them to add an option to disable optix. That being said, I’m always willing to suggest some random things. lets try this:

around line 85 you have this bit

  cmake -G "$generator" "$srcdir/blender" \
        -C${srcdir}/blender/build_files/cmake/config/blender_release.cmake \
        -DCMAKE_BUILD_TYPE=Release \

try adding


in that list.

Did not seem to make any difference.

the Optix dependency wanted me to download a file from nvidia and place it in a temporary folder, which needed me to register an account with nvidia…

I found a bugmenot account that worked and so I just did that step as mentioned above.

It seems to be compiling now without issue.

Thanks for your help regardless.

on our side you can turn optix on/off with the switch i mentioned, if arch demands you download optix anyhow probably best to file a bug with them.

I wanted to follow up in case others where dealing with this issue.

So I’m back on a new linux machine, trying to figure out a way around this again.

I followed your steps again (LazyDodo), edited the build files and added "-DWITH_CYCLES_DEVICE_OPTIX=OFF " (minus the quotes) to the build file, this time around the build process rendered this:

Building optix…
-> Please manually download to /var/tmp/pamac-build-YOURUSERNAME/optix from

I followed those steps again, and it’s working.

Thanks again!.

I know I don’t have a RTX card, but I know no other way around this being a linux noob so I found a way to satisfy the process.

NOTE: without adding what you recommended I could not advance, it actually just told me, missing optix, deal with it. With your line it actually gave me the hint as pasted above how to resolve this.