Blender 2.8: “Unable to open a display” by the rendering on the background (CYCLES)

This topic is similar to Blender 2.8: “Unable to open a display” by the rendering on the background (Eevee)
background rendering get stopped by

Unable to open a display

when using it on server , but it’s ok in my laptop.

The used command:
blender "Dual#11.blend" -E CYCLES --render-output //frame_##### -F PNG -f -2 -b

My main question here is whether blender Cycles engine supports headless rendering or not?

ps: server os is ubuntu 18.04, my laptop os is Windows 10

Cycles should work in a headless setup as far as I know.

Did the same thing in 2.79 work on this system? If so that could be reported as a bug.

Can you try moving the -b option to be the first option, i.e. blender -b "Dual...? The option order matters and you’re starting the rendering here with -f and only then activate background mode with -b.

@brecht I tried with 2.79 and 2.80 and 2.81 all gave me the same result:
linux output
but the command works fine in my laptop
windows output(with screen)
will appreciate if you look into output.
I used a simple project to create output:
http://www.mediafire.com/file/tf4op7x334i4j8x/Blender_Intro_Template_%23209.zip

I don’t think that really matter because as I mentioned it works fine when i have a screen.

I can render the default cube headless just fine, but this file i get the same coredump you do so it’s probably something specific in this file. It be best if you’d file a bug at this point. (and attach the file)

Well, yes, if you have a screen then wether you enable background rendering or not will not matter. It’s when you render on a machine without a screen (or more precisely an X server on Linux) that the -b option will matter.

So I’ll suggest again: did you try rendering with the -b option as the first argument on the system where rendering otherwise fails with Unable to open a display?

So I tried as you suggested and moved -b at first, but still same result.
blender -b "Dual#11.blend" -E CYCLES --render-output //frame_##### -F PNG -f -2

I tried the simple cube, in simple cube there is no Sync and Compositing required, but in the linked project there are some syncing and compositing that’s when the error shows up.
right after line 316 in windows output.

Fra:624 Mem:239.67M (0.00M, Peak 240.63M) | Time:00:00.76 | Syncing Empty
Fra:624 Mem:239.67M (0.00M, Peak 240.63M) | Time:00:00.76 | Syncing Plane.101
Fra:624 Mem:239.67M (0.00M, Peak 240.63M) | Time:00:00.78 | Syncing Plane.100

Fra:624 Mem:162.96M (0.00M, Peak 240.63M) | Time:00:20.52 | Compositing
Fra:624 Mem:162.96M (0.00M, Peak 240.63M) | Time:00:20.53 | Compositing | Determining resolution
Fra:624 Mem:162.96M (0.00M, Peak 240.63M) | Time:00:20.58 | Compositing | Initializing execution

Strange. I tried the file you linked on a (Red Hat) Linux system without a GPU and without any X server running and it renders without errors using the command you use. This is with the slightly older blender 2.80.39.

And the position of the -b option indeed doesn’t matter here, apparently because the frame render with -f causes the UI to never get loaded as Blender exits after rendering.

Which blender are you using, official binaries or custom built version?

Ah! Just tried the latest official binaries (2.80.75) and with those I also get the error you’re seeing! So it indeed appears that when the compositing step starts the text overlay is rendered (directly after rendering is Finished) an attempt is made to open a display, even when running with -b.

Quick guess after looking at the file: there’s two scenes in there, Scene and TEXT overlay. Both have their own setting of the renderer to use (set to Eevee in the file). When you use -E CYCLES from the command line it only sets the renderer on the current scene, leaving the other set to Eevee, which won’t be able to render headless as its directly tied to OpenGL.

Haven’t tried a workaround, but the above looks to be the issue.