Asset Browser - Placed assets do not update when source asset is updated

Hello,

When I update the source asset, any copies of the asset placed in other scenes do not update. Is this because they’re not currently linked back to the source asset?

Currently, I would have to place a new version of the asset to see the updates. This is fine for a very small number of items in the scene, but doesn’t scale well with larger scenes where an asset might be placed hundreds or thousands of times.

Thanks,
Matt

The last time that I tried asset browser only created a copy of the asset in the file. For that reason a simple blend file with few assets weight a lot

For the time being, collection type assets are defaulted to linking, whilst object type asset are defaulted to appending. For now there’s no way changing this defaulted behavir. Linked assets in a project will update when you reopen the scene or you reload it in outline>blender file.
Please take a look at my proposal, it meets all your needs and brings much more useful functionality. https://devtalk.blender.org/t/variation-system-my-proposal-based-on-current-asset-browser

Yes! This is very similar to what I had in mind. Being able to encapsulate multiple assets into one entity would also be very helpful. I.e., I have three meshes from the database that can the be parented under a locator, and the locator itself can be added to do the database as a prefab.

Really excited about this feature set. I think it will help organize all of the great asset packs people download and make it more accessible to have a working library.