An object in edit mode in another workspace, effects my ability to undo in the VSE. Why?

I spent about an hour trying to figure out why undo had stopped working in the blend file I work in. Most of my work at the moment is in VSE, I’d completely forgotten that I had an armature in edit mode. It’s not a freak occurrence either. I’m using Blender’s VSE for blender tutorial work partly because I can switch workspace quickly to double check that my advice is correct on technical details.

-Could we get a warning to remind us that we’re in edit mode in another workspace?

-Or go into object mode automatically when switching to the VSE?

Unless someone is already working on the undo system to fix this issue?


Hmm, with 2.83.4 I can’t reproduce what you’re seeing. Should this be similar to what you’re doing?

  1. Add an armature in the Layout screen and enter edit mode on it
  2. Switch to the Animation screen and change one area to a Sequence editor
  3. Start editor strips in the VSE, including doing undo. In my test I added a few image strips, moved them around, doing undo, etc.

Undo seemed to work without problem in the VSE for me

1 Like

Ok it seems to be contextual to what I have in my Blend file, I have this issue in all recent builds of blender, but not on a fresh blend. I managed to strip down the blend file, and you if you open it up with the interface of the blend file, you’ll be in the video editor.

I THINK it’s to do with strips that are referencing a masked video in another scene. Try adding keyframes to the opacity of a color strip, and try to undo. Then try going to the layout tab and exiting edit mode, and try the same thing in the video editor. You should see the issue.


Actually, with that file in 2.83.4 I don’t see issues with undo. It works for keyframing opacity of one of the strips independent of the mode of the armature. But since this seems to be a 2.91 file it might not fully do the same thing in an older, especially LTS, release?

It was made first in 2.82, and eventually used with 2.91, but I’m having this issues in the daily Alpha and Beta and the LTS. I should start listing my specs since this may possibly be my setup. I’m using windows 10, with a Xeon E5-2690 v4 @2.60ghz. The noteworthy part are the 14 cores and 28 threads. I’ve also got 32 GB of ram. So as you can see, in theory it should work well, but my CPU is more commonly used for servers, rather than Blender.

Did you try key-framing, clearing key-frame and then undoing that? This is where I experienced most of my lost work. I’d accidentally clear a key-frame and then not be able to restored my lost animation work unless I had a backup of the blend file. Fortunately, I can work around this rare paper-cut by not being in edit mode over in the other workspace.

Global undo is ticked in my system preferences as is default. My Undo Memory Limit is ‘0’ (Unlimited), and my Undo steps are set to (32). Any other settings to report, let me know.

Also take note, I’ve been using the Addon; VSE EASY PROXY

I might try the latest version of easy proxy too. Maybe it’ll help, but oddly enough, I experience the problem whether or not the addon is switch on.

It’s impressive that you can get full scale 1080p videos to play at 60 frames per second using that addon, but it may also be related by some possibility.