AMD Radeon RX 580 OpenCL not working since 2.81a

Using an AMD Radeon RX580 on Ubuntu Linux with the AMD drivers from their website.

clinfo displays the following

Number of platforms 1
Platform Name AMD Accelerated Parallel Processing
Platform Vendor Advanced Micro Devices, Inc.
Platform Version OpenCL 2.1 AMD-APP (2686.5)
Platform Profile FULL_PROFILE
Platform Extensions cl_khr_icd cl_amd_event_callback cl_amd_offline_devices
Platform Host timer resolution 1ns
Platform Extensions function suffix AMD

My Cycles has stopped working on GPU since version 2.81a. Does anyone know whats going on ? Or what has changed since 2.81a.

Thank you.

You search and find this before open new post?

Did you read my post ? OpenCL is working, but only on an earlier release.

since 2.81a are near to be 3 versions, 2.82, 2.83.x and in one more than one week 2.90 and not only on an earlier release.
You have check for already report bug in ?
If you have same problem in 2.90BETA you need (should /must) make one good bug report (if not already made from other, i doubt on this), this problem can be one bug that stop Blender 2.90 to be released until fixed.

You have problem to enable OpenCL hardware in OpenCL preferences or what?
OpenCL hardware still not working with default setting and after re-set Preferences to use it?
not working and has stopped working are too generic to have proper reply

You read other post?

1 Like

Make sure you have installed the most recent Pro drivers. If that doesn’t help, issues like this are for the bug tracker.

1 Like

The linked thread did not work for me as …
./amdgpu-pro-install --opencl=legacy,pal --no-dkms --headless --dryrun

returns pro install cannot use --no-dkms

What worked for me was the latest 20.04.1 AMD Driver and …
./amdgpu-pro-install --pro --opencl=pal,legacy

Loading render kernels does take a while, Its quite fast in 2.90 though.