Addon bl_info and minimum Blender version in Blender 3.x

I don’t know if this is a problem or my ignorance of the subject. Any explanation appreciated.

From this page in the manual, and I am aware that the information could be out of date: Add-on Tutorial — Blender Manual

It says this:
is a dictionary containing add-on metadata such as the title, version and author to be displayed in the Preferences add-on list. It also specifies the minimum Blender version required to run the script; older versions won’t display the add-on in the list.

I have verified that if I use “blender”: (3, 0, 0) in bl_info that the addon does not appear in the list in 2.9x.

Regarding Blender 3.x, if I try (3, 5, 0) to limit availability to at least Blender 3.5, the addon still appears in 3.4. I tried various combinations based on the binary file version number, see below, and even (4, 0, 0), the addon still appears.

I tried an included addon by replacing the Node Wrangler addon in 3.3.6 with the addon from 3.4 which uses “blender”: (3, 4, 0) in bl_info and it appeared.

Opening a .blend file in a text editor shows the Blender version number as e.g., v303, v304, or v305. Does this have anything to do with why the version number written in bl_info doesn’t seem to do anything?