2.79-like unit display

I wish the unit display could be reverted as it was in 2.79. So when I type in “1m” or even “1km” the text field would show “1m” and “1km” instead of showing the values as “100cm” and “100000cm”. This worked so well in 2.79.

Pick the Adaptive option for the length setting in unit properties.

I have. But when the Unit scale is set to “0.01” and I enter “1”, the text field defaults to “1m” unlike in 2.79 where it used “1cm”.

Works for me, though my build is a month old…

With Length at “Adaptive” and Unit Scale set to “0.01” you get “1cm” when you type just “1” into the text field?

No, as per your opening post, if I type 1cm I get 1cm. But indeed, if what you meant was to be able to just type 1 and get 1cm, then no, that doesn’t work. I was looking at the OP and missed

bit in the later reply.

I suppose the unit system edge length adaptive property only affect the display of units, not the inputs interpretation. Not sure if intentional or just an oversight.

I guess it’s was overseen. That’s why I posted it here and hope that some developer takes notice. My request was ignored once before. It’s hard to get answers sometimes which is a bit sad.

Added it to Paper Cuts as well. Maybe it gets some exposure here.

I did a quick mockup of something that might be better usable.


Any chance that this issue can be solved before the final release?

Here’s a summary of the problem again.

*) When units are set to “Centimeters” and I enter “1m” or “100” it should be displayed as “1m” instead of “100cm”. Of course the same goes for other higher denominations like “km”.
*) “Adaptive” is working except I can specify the denomination that I want to be used when I enter values without denomination. It’s always meters. So if I enter “1” and I want this to be “1cm” by default, there is no way to define this. In 2.79 this was possible.