Xray selection in 2.8 is still not a solved problem


Xray selection in Blender 2.8 is still not solved, and poses some issues for both new and existing users.

Currently, if you are a new user, you will sooner or later come across an issue of not being able to select mesh elements that are not visible, covered by mesh elements in front of them. When you start looking around the user interface, you will not find any button or tool named in a way that would imply possibility to enable “select through” mode. The button to do this is very inconveniently named “Show whole scene transparent.”

It won’t be obvious to a new user why would they want to ever just show whole scene transparent, or that it in any way relates to ability to select occluded mesh elements. It’s one of those things that will require google searching some obscure forum posts to figure out. On top of that, once they actually learn that the two are connected, it may cause a further issues as wanting to be able to select through does not automatically equal wanting to see the entire scene transparent. This can be alleviated by setting Xray value hidden away in shading popover all the way to 1, but that’s also something which will require going outside of Blender to find out.

Proposed solution for this:

  1. Rename “Show whole scene transparent” to something like “Xray selection”
  2. Change default Xray value to 1.0
  3. Rename Xray value to something like “Xray opacity”

This solution will accomplish following:

  1. It will be immediately obvious that the button is related to how the selection behaves, without having to go outside Blender and start Googling.
  2. Xray selection won’t suddenly unexpectedly make entire scene transparent without it being the intention of the user, resulting in confusion.
  3. The name of the button will make it obvious that the setting in the shading popover is related to that button.
  4. It will remain optional for users to make Xray turn entire scene transparent if they wish to do so.
1 Like