Viewport background setting is present in dropdown menu for solid mode but not in material preview

I was confused because in the shading workspace the background color for the material preview was set to the preview display color and in the modeling workspace it was set to the theme background.
It took me a while to find out that you can set this in the solid dropdown menu.

Also add the setting to the material preview dropdown.