Unable to run blender 2.80 in RHEL/CentOS 7


#61

OK, So I have been struggling with this for weeks now with no luck. obviously building blender on Centos is beyond my technical capabilities. the question now should I just abandon ship and jump and leave Centos for another distro? or is it something that will be addressed during beta and release candidates? will we have binaries for RHEL and Centos?


#62

Hi @AhmedBarakat , sorry to see you are having issues.
In the past few days I had issues as well building through the docker, but was only due to some dependency issues. Yesterday night built just fine (cheers devs :slight_smile: )

The benefit of using docker (to me) is that you don’t end up polluting your system for one off built.
now to go back to the @mon docker…

first off ensure you have docker installed running :

docker pull hello-world

if everything is fine then run :

docker run mattiasohlsson/centos-blender-2.8-builder

This should pull and run the build image.

You can then extract the result build with :

  docker cp <your result docker name>:/blender-2.80.0-git20180925.df5cb4d-x86_64.tar.gz ./

hope it helps.
L.


#63

Hi Lorenzo, I appreciate your help and taking the time to put this guide for me.
my problem with the docker was that it filled up my root during the pulling and building. and with no luck I tried moving it’s default folder to my secondary drive I followed 3 different guides I found and non worked.
I guess I will try that again and see.

Thanks again for your support.
Ahmed


#64

@AhmedBarakat, pleasure :slight_smile:
if you have issues with docker space, try running this command:

docker stop $(docker container ls -a -q) && docker system prune -a -f --volumes

please note, this command will cleanup any docker thingy you have around, so be careful.
Let me know how it goes.


#65

I struggled a lot with this with no luck. and I messed up my system with all the libraries I was trying to install. and I discovered I lost too much time over this. so one day I decided to just re-install a fresh system and while I was at it I just decided to switch to Ubuntu. few days into Ubuntu, definitely I miss how solid and stable Centos was. but Ubuntu is more user friendly for sure. apt is a joke compared to yum for me. but will see how it goes. important thing I managed to get all my apps to run and I can download the 2.8 builds again.
Thanks for your help.
Ahmed


#66

I’m trying to build Blender 2.8 on CentOS and I get an error with “make lite”.
Build is working in master branch.
Can you tell me what it could be?
(Everything from install_deps.sh is ok except OSL I didn’t succeed to build)

Here is the error:
/home/user/blender-git/blender/source/blender/editors/animation/anim_channels_defines.c:344:7: note: in expansion of macro ‘GS’
if (GS(ale->id->name) == ID_NT) {
^
cc1: some warnings being treated as errors
make[3]: *** [source/blender/editors/animation/CMakeFiles/bf_editor_animation.dir/anim_channels_defines.c.o] Error 1
make[2]: *** [source/blender/editors/animation/CMakeFiles/bf_editor_animation.dir/all] Error 2
make[2]: *** Waiting for unfinished jobs…
[ 4%] Building CXX object intern/eigen/CMakeFiles/bf_intern_eigen.dir/intern/linear_solver.cc.o
[ 4%] Building CXX object intern/ghost/CMakeFiles/bf_intern_ghost.dir/intern/GHOST_TaskbarX11.cpp.o
[ 4%] Building CXX object intern/ghost/CMakeFiles/bf_intern_ghost.dir/intern/GHOST_ContextGLX.cpp.o
[ 4%] Building CXX object intern/eigen/CMakeFiles/bf_intern_eigen.dir/intern/matrix.cc.o
[ 4%] Building CXX object intern/ghost/CMakeFiles/bf_intern_ghost.dir/intern/GHOST_SystemPathsUnix.cpp.o
[ 4%] Linking CXX static library …/…/lib/libbf_intern_ghost.a
[ 4%] Built target bf_intern_ghost
[ 4%] Building CXX object intern/eigen/CMakeFiles/bf_intern_eigen.dir/intern/svd.cc.o
[ 4%] Linking CXX static library …/…/lib/libbf_intern_eigen.a
[ 4%] Built target bf_intern_eigen
make[1]: *** [all] Error 2
make: *** [all] Error 2