Spacebar "instantly" picking

Video uploads don’t work, so I uploaded a video to YouTube to demonstrate the exact issue.
Every other space-bar press, a selection is made instantly, without any mouse movement. You can see that the toolbar is made on a new tool other than the selected one, and it decides that by logic (it assumes the toolbar is made under the active tool) my selection has changed. Might be OSX specific (Mojave 10.14.6) as I haven’t seen anyone else complain about this, and there’s no way people would be OK with it.

I can’t reproduce this on my machine. I don’t have a mouse attached at the moment, just the trackpad.

Do you have any other peripherals attached that could cause such input?

Maybe try a different mouse too?

It’s happened to me before too on Windows 10 so it’s not a mac issue. It was intermittent and to be honest I just put up with it; I guess I should have posted here.

I tried again with all peripherals disconnected (MacBook Air), it still happens. This is without any input except the spacebar, not even 1 pixel of cursor movement (as shown in video, the cursor is perfectly stationary).

Interestingly, I almost got a false negative by creating a new scene, adding a plane, and sculpting on that. The issue didn’t occur until I made a cube and moved it from the origin, rotated the camera, and then sculpted on that. After which, it also occurred on the plane.

Thanks for your interest in this issue.

Edit: I am specifically inclined to believe it isn’t an input issue, because the popup menu is displaced by default. You can see it if you pause on the frame which it appears in the video, the cursor is hovered over a different item than the one which was active, a peripheral could not have moved the popup.

It took a while, but I was able to reproduce this, and it happens outside the sculpting mode


  • spacebar is set to pop up Tools


  • in 3dview select the Measure tool
  • with mouse cursor close to top edge of 3dview press spacebar
    • note that this edge has to be close to window edge
    • menu has to be drawn with a different location forcing the currently selected item to be outside the mouse cursor reach
    • whatever tool is under the mouse cursor gets selected and activated

I haven’t tried with latest from master yet. Could you please see if the bug still exists with that, @horusscope? If it does, please create a bug report at



1 Like

Thanks for your trouble, I went ahead and made a bug report and linked back to this thread. The issue exists in master/2.81a

And thanks to you for logging, even though it ended up being a duplicate (: