[Solved] ImportError: numpy issues?

Why am I getting this now?

ImportError: Something is wrong with the numpy installation. While importing we detected an older version of numpy in ['C:\\blender-git\\build_windows_Full_x64_vc15_Release\\bin\\Release\\2.81\\python\\lib\\site-packages\\numpy']. One method of fixing this is to repeatedly uninstall numpy until none is found, then reinstall this version.

Armory worked fine ,but after updating Blender to commit f2c3dc94b1cd0bed17863faa0c6044edb29d6566 I started getting this message. Tried several things and can’t seem to solve this. I’m not seeing ,but one version in that location ,so what’s this message mean?

Usually means the numpy folder in blender’s local site-packages has been partially overwritten with a different version.

I’ve resolved this in the past by

  1. going into 2.81\python\lib\site-packages and deleting all numpy folders and
  2. in 2.81\python\bin do python.exe -m pip install numpy

This fixed it…

It’s generally caused by unpacking/building multiple versions of blender on top of each other, if we changed lib versions and/or moved addons you’ll run into issues like this. best to delete your bin folder and rebuild the INSTALL project, it should work it self out.

you should never have to deal with pip for packages we ship out of the box like numpy.

1 Like