Shrink/Fatten can't be set to use Offset Even by default in keymap editor

I use Shrink/Fatten all the time to move along normals.

I never have any reason to not use Offset Even so decided to modify my keymap to have that enabled by default.
Turns out when you check the box in the keymap window it has no effect like it does for other options/tools and I still have to manually set it to true after starting the tool.

If I use the Pie Menu Editor it works when added to a pie menu, but weirdly doesn’t when mapped to a key unless I set it to “on confirm” if that helps with tracking down the issue.

2 Likes

It’s quite counter intuitive, but certain parameters or certain tools remember their state for the duration of Blender session, or maybe for the duration of Edit Mode… I don’t know really, it’s super confusing and messy, as much of Blender is.

Anyway, you can verify that easily by changing the property, and then restarting the Blender and checking the state of the setting the very first time you use the tool after Blender launch :slight_smile:

This is simply a bug with this particular tool.
Everytime you use the hotkey it doesn’t check the “Offset Even” box but does respect the “Use Snapping Options” box if you turn that on in the keymap.

I think usually the difference in when it remembers and when it doesn’t is how the tool is fired, if it’s from a hotkey it should always have the default values assigned to that bind.

If it’s from one of the menus or the spacebar search it remembers the last settings you used in that blender session.

1 Like

same thing with spin angle value

1 Like

I honestly can’t think of a reason anyone wouldn’t want even turned on. Its the same with the solidify modifier and operator as well as the extrude faces along normals operator. Report this as a bug.

1 Like

I did https://developer.blender.org/T66600

It got merged with https://developer.blender.org/T54325

For a brief period we had it on by default, but got some user complaints that it was different from 2.79 so it was changed back. If you use Shrink/fatten with Suzanne with Offset Even, you get a spiky result.

Even so, I think by far the most commonly useful method is using Offset Even

Well, I’m complaining that the default doesn’t make sense in 99% of situations (I’m being generous here, because I can’t really think of a situation that I haven’t preferred it). Can we have an official vote?

I agree - in all the most common cases you would want Offset Even to be enabled.

2 Likes