Selection intersection

Today I’ve noticed some strange thing. If I try to deselect some object, that has some other objects behind it, it’s not deselecting. It just add to selection backgound objects.
Try to do the same thing as on my screenshot. You will see that if you try to deselect second cube by clicking on the top right corner, it will not work. It works only if you click on the left bottom corner where is nothing behind it. In this case with cubes it’s not so critical, but sometimes it can be very hard to find the right angle to click on the free space.

To deselect an active object, click Shift-RMB one time and hence, two clicks if the object is not active. Note that this only works if there are no other objects under the mouse. Otherwise it just adds those to the selection. There appears to be no workaround for this bug.

yes, but it would be nice to get rid of this thing. So annoying. In some complex scenes there can be almost no ways to deselect some objects if you selected them by mistake. Just abandon all your previous selections and start to select everything from the scratch.

of course we can press " / " and isolate all selected objects, then deselect something and go back to the whole scene. But if we try to make blender better, there is no excuses for this workaround

  1. I think this is intentional behavior allowing you to select objects behind by clicking through.

  2. You can deselect, just click slowly. The first Shift-click makes the object active, pause and the second Shift-click will deselect.

  3. Also you can use Ctrl-RMB and Shift-Ctrl-RMB shortcut to select the object by its center point rather then its contents.

    There’s a bug with Shift-Ctrl click (T56411), but you can disable “Extend” in the Keymap yourself.

  4. If the objects are overlapping in the view, you can use Alt-RMB to cycle through possible choices.

    But there is also a bug, with Shift-Alt click (T50800). :cry: