Problems building and running Blender afterward


#1

Hi! I’m looking to get into contributing to Blender. I have a list of some things I think might be simple to tackle, so I’m starting out by getting set up to build Blender from source.

I’m using Manjaro, so I followed the instructions here

A few times running make I got an error similar to what follows. I tried disabling OpenVDB, then Alembic and that worked.

Makefile:160: recipe for target 'all' failed
make[1]: *** [all] Error 2

So the build is now finished, but I think something didn’t work correctly, because when I run “./blender”, I get the following error. I’m running this command because the .desktop doesn’t work either.

./blender: error while loading shared libraries: liboslcomp.so.1.9: cannot open shared object file: No such file or directory

Install_deps.sh finished, so I’m not sure what the problem is here, does anyone have an idea?

I’m sorry that this is sort of a nooby question, but I’ve been trying to get this to work for quite a while, I even switched distros hoping that might help.

Thank you!


#2

I know I probably need to provide more detail in the error messages. Tomorrow I will start the process from scratch and document the error messages I receive better. But I still feel I might be missing something which is why I posted.


#3

Ok, I have no idea what I did differently, or even if I did something differently, but I restarted the process and it worked fine this time.

I can’t delete the post, but feel free to.