PointCloud Feature Implementation - Need Guidance

This is an example screenshot, with my branch, your code is in place, but for some reason it’s not kicking in, the same happens if I use the “blender-v3.0-release” branch applying your render patch:

Thanks - I did the same to test the patch before I submitted it, so I will test against the latest blender release branch soon. Sorry it didn’t work out for you, let’s figure it out :slight_smile:

edit: I can see that my patch already has conflicts with blender-v3.0-release, so I’m noting the commit I originally branched off of: 7b530c6096112c9a15db2e637d44012e248f1ab4

If you have time before my next update, perhaps you could specifically check out that commit, and then apply the commit? Or, since that will take time, I’ll adjust the conflicts and hopefully reproduce your issue :slight_smile:

1 Like

I only recognised two small conflicts, and it was that the types “hair” and “pointcloud” were already present in the code, but that’s it, super small conflicts because it was working already :slight_smile:

If I find some moment I’ll try, however I have little experience doing a build from an specific commit, but I’ll try :slight_smile:

No worries.
To do it, you would

# save all git changes, git stash or what have you
git checkout 7b530c6096112c9a15db2e637d44012e248f1ab4
git apply <diff>
make

more or less

1 Like

I’ve created a fresh diff which merges against master but there really wasn’t functionality change.
If we want to try a few different things, I’m open to creating some diffs and sharing them with you so we can see if anything changes, but it would be much easier (and saner) if we can reproduce your results.

Ihave to check what’s happening, because for me it does not merge cleanly against blender-v3.0-release, I’ll tell you more later, I have a meeting now :slight_smile:

EDIT: I think the merge problem was my fault, I just tried again and it applied cleanly :slight_smile:

I’ll come back to report

Update, everything worked fine :slight_smile:
I detected some crash while editing a shader for the points with viewport rendering active, connect some texture, I tried with noise texture, change some parameter and you get a crash, I’m not sure if it’s your patch’s fault or not, I’ll have to test deeper :slight_smile:

EDIT: When I say everything worked fine is not only in blender 3.0 branch, also in my own branch, bonemaster300, where I have the @KevinDietrich alembic patch implemented… AWESOME :smiley:

5 Likes

I’m wondering a thing, are there other primitives that can be used for such task and that give similar fast result?

What I mean is for example a cube or a cuboid, that would be very useful for sand simulation, not required, but useful, also facing planes could be useful.

Keep in mind I ask this without any knowledge about if it’s possible, if other primitive exists, etc…

I’m so relieved to hear that you got it working. I’ll test the behavior you described and report back.
As for other shapes, a little detective work will show that other disc styles have been implemented: Login

So this could be stacked on top of this - my initial thought is to build with a sphere first and add support for other features further on? I’m new around here so I’m not super familiar with the ways of working :slight_smile:

Yes, I think that should be the way to proceed, IMHO better to go with a minimum viable product, that is easier to have under control, and once it’s implemented go ahead and improve it :slight_smile: so lets start with points as spheres to be safe, although @brecht can give a better and proper answer to this :slight_smile:

2 Likes