Opensubdiv Versioning Compiling Problem

I ran, and noticed Opensubdiv updated to 3.4.0. Since then, I haven’t been able to compile anything, getting errors like:

error: undefined reference to ‘OpenSubdiv::v3_3_3::Far::PatchTable::GetPatchParams(int) const’

It looks to me like the updated Opensubdiv to a version which is unused. (3.4.0 vs 3.3.3).
How can I fix this? Could I undo the update to opensubdiv, and how? Using Ubuntu 18.04, btw.

Thanks :slight_smile:

As it seems, based on what I’ve encountered, if you’re doing regular git pull (make update) and build, some parts of Blender is not being re-build as no changes had happened in the meantime for those parts, and those parts may be built linking previous version of OpenSubDiv for this scenario.

So, make sure you run install_deps once again as it has changed, then clean rebuild Blender again (like make clean or, remove build_linux_full or alike directories). This solved my linking issue for this same problem. (another probable option would be to remove those portion which depends on OpenSubDiv and rebuild just those, but I think clean build would be cleaner bet)

Thanks :slight_smile:

Thanks. ‘Make clean’ fixed it.