Newest build of Blender 2.8 (May 1 2019) really laggy

First time posting here. I have run into a lag issue with Blender 2.8. I had a previous build of Blender 2.8 but decided to download the May 1 2019 version. Now when I sculpt in it, it is super laggy and it is almost impossible to get anything done. I also tried just rotating the camera around and moving around the scene, but to no avail, it is still too laggy. Are there any settings I can change to fix this? I am working on a Macbook pro.

Here are my specs: MacBook Pro (Retina, 15-inch, Mid 2014) 2.5 GHz Intel Core i7 16 GB 1600 MHz DDR3 NVIDIA GeForce GT 750M 2 GB Intel Iris Pro 1536 MB

I was able to do all of my 3D work all on my Macbook pro while I was in school for about 4 years. I had minimal to no issues when it came to lag. I used Maya, Zbrush, and the Substance programs. So I assume that my laptop isn’t the issue. I am still pretty new at Blender. Any tips or advice is greatly appreciated! Thanks! :smiley:

It’s being worked on:

O ok cool. Thank you for replying.