Network Render Test with flamenco

You’ll have to check the logs as sent from Worker to Manager, as well as the logging output of the Manager itself. That should give you more info.

1 Like

Sorry to bother you again, I’m not even sure this is the right place to come for help,
but I really can’t get my head around to what’s going on and I need to launch a big render by the end of the week.
My manager is stuck in a loop like this :

My workers give me this error :
2021-03-03 10:17:27,930 WARNING flamenco_worker.worker.FlamencoWorker.fetch_task Error fetching new task, will retry in 10 seconds: HTTPConnectionPool(host=‘’, port=8083): Read timed out. (read timeout=3)
I’ve tried removing all my projects from the cloud, setting up a new manager with an empty project, but it still tells me that I have 12511 Tasks and 35269 Upstream Queue.
If a start a new render via flamenco/blender, the manager refuses to give tasks to the workers, and I see the above task number incremented by the number of frames I have asked to render.
It worked “fine” (apart from the fact that the jobs were stuck on queued), today it’s not rendering at all.
Any idea what I could do ? I wouldn’t mind creating a new blender cloud account if it’s the only solution…

Please don’t post screenshots of text. Just paste it, or pipe it to a file and attach that. You can’t search through screenshots, or copy-paste text from it.

Your worker can’t connect to the Manager. This is not solved by doing anything on Blender Cloud, as it’s a problem that’s local to your network. Is the Manager advertising the correct URL to the workers? Does the machine the Manager runs on have a static IP address? Or is the DHCP server set up to always give it the same IP address? This is a necessity for a stable connection – the Manager isn’t equipped to deal with changing IPs.

Removing projects from the Cloud doesn’t tell your Manager to forget what it has queued. This is like demolishing a house, and expecting the pose office to burn any letters that were queued up for delivery there. Run flamenco-manager -purgequeue to purge the Manager’s outgoing queue.

1 Like

My apologies for the screenshots, I will keep that in mind, I thought it would be more readable this way.
I finally managed to get the farm up and running again. It was the workers that apparently were sort of clugging the manager with tasks (sorry for not being more precise, in my haste of trying to figure things out I did not take the time to save logs). I’m still not sure what I did wrong to get things so messed up. The network and fixed IP adresses were all fine, I could ping all the computers and they could all access their shared folders.
The -purgequeue command did purge a few tasks, but I had to run it like twenty times before the upstream queue was actually empty, as tasks kept coming in thousands by thousands. I purged 4000, it appeared empty on the managed interface, then as soon as I started the manager again, 3800 came back. But in the end it did not make things work any better.
What did the trick was erase all the Flamenco-worker folders from my workers, and replace them with a fresh Flamenco-worker folder (I made sure to keep the same IP adress), now all the workers can connect to the manager, and I was able to start my render just before the week end. Thanks to blender-cloud I’ll be able to keep an eye on my renders from the comfort of my home :wink:
I hope my endeavours can be of help to someone else someday.

Hey gusy, im fighting with the same problem!

Error in settings: blender_cmd ‘{blender}’ does not exist

can anyone explain this problem to me would be great!

check it!

1 Like

Flamenco does support spaces in a path, but you have to quote the path. This is necessary to make the distinction between “space in executable path” from “space to separate executable from arguments”.

Won’t work:

C:\Program Files\Blender Foundation\Blender X.XX\blender.exe -factory-startup -no-audio

Will work:

"C:\Program Files\Blender Foundation\Blender X.XX\blender.exe" -factory-startup -no-audio

This is the same as you see when you create a shortcut on your desktop to Blender. It’ll have the path "C:\Program Files\Blender Foundation\Blender X.XX\blender.exe" including the quotes.

1 Like

It’s me again…
I’ve upgraded my manager to 2.7.3, and pretty much tried a clean new setup, same for the workers to support Blender 3.0.
But when I want to link my manager to the Flamenco Manager on I get this error on the webpage :


Link check failed auth check:


Link expired
Linking could not start: JWT token authorization required: Authentication token is required
Revoking the Token from any manager (even created a new one) creates another orange error pop up saying : Error revoking auth Token: PRECONDITION FAILED

I can however render stuff via my farm, but cannot do anything via the manager local webinterface, it is locked with a AUTH Error.
Anything I did wrong ?

Authentication is iffy in the current Flamenco Manager implementation. If you don’t need it (for example you have your Manager internal on your network, and only people you trust can reach it), you can simply disable it by putting this into your flamenco-manager.yaml:

    disableSecurity: true

For more help with Flamenco, please pop over to #flamenco on Blender Chat. This forum is not for support questions, but for discussing development.

Hello Sybren,
Is it possible to have multiple workers on one big computer with multiple graphics cards ?

Hi @Axono

This is not a support forum, sorry (see the blue bar at the top of every page). I know above it’s become a bit support-like, but I don’t think that’s a good idea to continue.

Pop over to as that’s a better place to ask questions.