Musgrave + OSL unpredictable behaviour

I’ve found a problem with Musgrave texture when using OSL and I don’t know if this qualifies for a bug report.

Steps to reproduce:
1: Enable OSL support.
2. For default cube create new material, add Musgrave Texture, preview it.
3. Change Texture Detail over 15, and Lacunarity over 3.780.
The result should look like the one on the right:


4. For comparison disable OSL.

Tested with Blender releases:
2.83
2.90 June 01 1d4bae856690
2.90 June 07 281319653e5b

You can report it as a bug. In general detail with such high values is not particularly useful, it’s just going to make rendering slower while adding more detail that’s too small to be visible or even representable as a float. Probably we’ll internally clamp the detail to avoid this problem.

1 Like

Thank you. It’s done.