Master does not recognize Nvidia GPU

Hi, set build environment from scratch and since then Blender does not recognize Nvidia GPU anymore in user preferences.
I have a lot of features disabled, don´t need it or does not compile.

Blender Skipping:
(audaspace;audaspace-py;bf_alembic;bf_avi;bf_collada;
bf_editor_space_logic;bf_editor_space_time;bf_freestyle;bf_imbuf_cineon;
bf_imbuf_dds;bf_intern_ctr;bf_intern_gawain;bf_intern_moto;
bf_intern_opencl;bf_intern_utfconv;extern_openjpeg;extern_sdlew)

CMakeLists.txt:
https://pastebin.com/3ug8Ti15

**System Information**
Operating system: Linux-5.0.5-1-default-x86_64-with-glibc2.9 64 Bits
Graphics card: GeForce GTX 760/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 418.56


**Blender Version**
Broken: version: 2.80 (sub 54), branch: master, commit date: 2019-04-06 12:26, hash: `rBcc73d59ad580`

I have no idea where I have to look to get it to work again.

Thanks, mib

You should never edit your CMakeLists.txt, once you run cmake all variables will be in your CMakeCache.txt in your build folder (which is also the file you should have posted), you can change them by passing -DSOMEVAR=somevalue to your cmake invocation. But never directly in CMakeLists.txt

beyond that, i’m guessiing you are looking to run make release in the blender source folder to get the release presets.

Hi, I work with Cmake Gui but will look in to DWORDS
Make lite is working but make release does nothing

make release
make: Für das Ziel „release“ ist nichts zu tun.

Will delete cache and start again.

Thanks for the help, mib

hummpf try applying this patch

diff --git a/GNUmakefile b/GNUmakefile
index 35960733858..6d0004e6a4f 100644
--- a/GNUmakefile
+++ b/GNUmakefile
@@ -30,7 +30,8 @@ Convenience Targets
    Provided for building Blender, (multiple at once can be used).

    * debug:         Build a debug binary.
-   * full:          Enable all supported dependencies & options.
+   * full:          Enable all supported dependencies & options, but without Cycles Cuda kernels
+   * release:       Full + Cycles Cuda kernels
    * lite:          Disable non essential features for a smaller binary and faster build.
    * headless:      Build without an interface (renderfarm or server automation).
    * cycles:        Build Cycles standalone only, without Blender.
@@ -195,6 +196,10 @@ ifneq "$(findstring debug, $(MAKECMDGOALS))" ""
        BUILD_DIR:=$(BUILD_DIR)_debug
        BUILD_TYPE:=Debug
 endif
+ifneq "$(findstring release, $(MAKECMDGOALS))" ""
+       BUILD_DIR:=$(BUILD_DIR)_release
+       BUILD_CMAKE_ARGS:=$(BUILD_CMAKE_ARGS) -C"$(BLENDER_DIR)/build_files/cmake/config/blender_release.cmake"
+endif
 ifneq "$(findstring full, $(MAKECMDGOALS))" ""
        BUILD_DIR:=$(BUILD_DIR)_full
        BUILD_CMAKE_ARGS:=$(BUILD_CMAKE_ARGS) -C"$(BLENDER_DIR)/build_files/cmake/config/blender_full.cmake"

(download link for diff)

Hm, same result, but make no sense anyway as make full does not compile on my system either, therefor I disable so many libs and features.

linux-workstation:~/blender-git/blender> patch -p1 < release_patch.diff 
patching file GNUmakefile
Hunk #2 succeeded at 196 with fuzz 2.
pepo@linux-workstation:~/blender-git/blender> make release
make: Für das Ziel „release“ ist nichts zu tun.

Mib

Allright then just make sure you turn WITH_CYCLES_CUDA_BINARIES on and you should be good to go.

The binyries would not help, I cant select Cuda device in user preferences.

Cheers, mib

Compiling Blender on Linux is kind of a nightmare, even on Ubuntu. But you don’t need to compile the cubins. When you render with CUDA (if it’s recognised in user prefs) it will compile the cubins on the fly. Why your card is not listed is probably a driver problem. If you use Timeshift (which you should as Linux bricks himself even with simple security updates sometime) you can just restore a state where it was working.

we worked it out on irc, the cuda toolkit wasn’t isntalled

great :slight_smile: 10 character

Hi Dodo! I have a similar problem, but on Linux MINT. I’m trying not to up a new topic yet. I’m not a tech and I’m just helping mine to find an answer, so we can install CUDA but Blender 2.82 doesn’t recognize it, as WIN does [Dual - I’m trying to migrate for Linux]. Can u help me? If so, what info do u need?

Not much i can do with the information given (which is basically “it doesn’t work”), i’d probably start by running blender with the --debug-cycles switch and see what that says about CUDA and take it from there.

Tks Dodo, but I could solve the problem already! :smile: