Improvement idea for "Fluid Domain UI"

Hi there,
It is hard to understand the difference between the “Collections/Effector” under the Fluid tab and the “Effector Collection” found further down under the Field Weights.

While the Effector Collection refers rather to FieldForces than to (Fluid)Effectors I´d suggest renaming that Field Weights option to FieldForces Collection.

cheers Linus