GSoC 2019 LANPR Development and Feedbacks

Hello!

The chaining was somewhat broken in a recent commit, which make the render result disappear. However your problem sounds different… It might be some recent code cleanups broke something unintentionally. I’ll check with your files.

Basic documentation will be available before the end of this week. Have fun and thank you very much for the test!

Here’s last week’s report https://wiki.blender.org/wiki/User:Yiming/GSoC2019/Week9

Ah I didn’t save that file since it was mostly just cubes… I’m trying to replicate it now but it is happening somewhat inconsistently. It seems to happen fairly often if you do following, though:
-Open b3d
-Select camera-ctrl0 to view through camera-set renderer to lanpr-shading look dev-create single line layer- press update (cube should appear in lanpr)
-Set lanpr chaining off-update (cube disappears)
-Set lanpr chaining on-update (cube appears)
-If you keep looping the last two (chaining on/off+update) b3d eventually crashes. (For me anyhow. Sometimes takes only once sometimes it might work for 6-10 times before crashing)

LANPR patch is up here! https://developer.blender.org/D5442

3 Likes

Go Yiming Wu go!
Fix what Antonio Vasquez asked then just master it finally! :zap::fire::zap:
I’m so happy for you and those lines! :smiley:

I did tests on windows 10 on a radeon HD 7600 and on an intel hd 4000 (both working with eevee)
on the intel hd 4000 all transparent. (blender only displays the selection outline)

on the radeon hd 7600 the situation improves, the rendering seems to work, but the framebuffer remains fixed to a frame if I try to rotate the scene …
f12 rendering seems to work, but I didn’t go deep into trop…

1 Like

Hi!

CPU mode is always fixed at camera. I’m discussing with devs to figure out a way to make it follow viewport as well, but it may be slow. Currently you need to align to your camera.

For the same reason. Auto update is disabled by default. Enable it to update the rendering when scene changes.

Let me know if there’s more hiccups.

1 Like

Hi Cheng
here’s what happens on the radeon …
in gpu mode it seems to work much better, while in cpu mode it remains a frame designed even if I refresh, and if I try to refresh button on cpu it lurks us a lot to calculate but nothing happens but it always remains as a frame drawn …

a question: is it normal that it’s all black with white lines?
I don’t know the use of LANPR so I don’t know if other settings should be made in the materials or other …

lanpr5

1 Like

CPU mode is a bit lack of response for sure… try moving frame with auto update enabled. (The results will always be stationary if your camera is not moving)

Of course you can adjust line styles, those options are under line layer sub panel.

autorefresh on cpu seems broken, does not calculate and we always see that drawing fixed in the background … actually it is better to say that only the silhouette of the selected object rotates …

it must be said one thing which is known with these GPUs, since AMD freezed the legacy drivers to 2016 this drivers have bugs that main blender devs have solved with GPU workarounds …
@mano-wii e @Hypersomniac they are aware of this

I’ll inspect. Currently if the actual camera object is not moving then the results will always be the same. :frowning: I’ll try to add a follow viewport option before the merge, but this could cause some unintended latency.

GPU looks good to me.

2 Likes

you are free to ask me if you need test on my gpus

1 Like

another question, in GPU mode, is this normal this appearance and disappearance of lines when zooming?
(is a bug on my GPU?)
lanpr6

edit:
I did tests with a simpler scene and it doesn’t work as it should … there are display errors … which I recognize … they are probably due to bug legacy drivers … @mano-wii knows this problems.

1 Like

This is partly due to z-buffer precision. Try increase viewport/camera near clipping value.

Did you add key frames to the camera or press playback?
If the time line its scrubbing it works, seems to evaluate the auto update in frame switch or something like that.
Just push play and move around looking though the camera. In perspective doesn’t work but looking through the camera it does work.
Its not the most intuitive thing to do to be honest, look only through the camera>activate lock camera to view> push play > move around, but it seems to be working here

[EDIT: there is actually a hint that comment about the frame changing :yum: i would add also “looking trough a camera” and the problem its solved :slight_smile: imagen ]

1 Like

This is looking really nice, change a lot since the last time i tested,
nice work @ChengduLittleA

3 Likes

I was trying to convert LANPR to grease pencil, works great in a box and a monkey however with this model cliking update strokes crashes the program

i was looking at my gpu (gtx 1070 8gb) and my system ram and it doesn’t move a bit, first thing i thought was that was a memory issue, but i don’t know doesn’t seem to be the case, am i missing something in the setup?

Can’t see the problem from the UI. Could be some internal reasons.

If you could provide a test file it’s much better to hunt down the problem.

Is there a way for me to send you a striped file version that i have been testing privately? The original model i did it for a commercial advertise, just to be sure i would like to keep the mesh on that file in a private environment not the openness of the forum

Use wetransfer. Send me the link will do :slight_smile: