File Output node missing Z-Depth input

Hi. I need to save parts of my composition in OpenEXR with the propper z-depth information.
The file output saves a black channel, no metter I activate Z-Depth options in the OpenEXR propperties in the sidebar.

Documentation: “To support subsequent arrangement and layering of images, the node can supply a Z-depth map. However, please note that only the OpenEXR image formats save the Z information.”

Is this a bug?