"Exclude from View Layer" Problem

Hi there, I don’t know if it’s a bug or a feature. To me it’s a workflow killer and caused me some pain during the last project.
I made a short screen capture that explains what my problem is. If I use the white checkbox to exclude certain collections from the view layer (which is a super nice feature to keep the Outliner clean and only show what’s needed and visible) and switch the collection back on again, the visibility of all sub-collections inside the parent collection are switched back on, too. Their original state is overwritten.
I would expect them to keep their state to make scene organization much easier.

1 Like

Answering my own post.

Oh thank you god! After thinking that noone else cared, this commit that came out a few minutes ago saved my life. THANKS!!!


Case closed :slight_smile:

1 Like

That developer just showed up a month ago with that patch🤗. There are a few more they have made waiting for review.


Dude. Been experiencing the same thing! The Exclude from View Layer button is great since it’s localized to this single view layer, but man the fact that it causes the visibility to be forgotten is a killer. Thanks for posting about this and pointing towards that patch!

Ok so I thought it was the same thing! Ha!
But what I was experiencing was objects having their hide in viewport setting forgotten.
Child collections hold this just fine. All other restriction toggles on both objects and collections also hold this just fine.
However, objects of collections that have exclusion toggled forget their initial state. Which is difficult to have happen if you want to have visibility on one view layer respected, regardless of whether exclusion of their parent collection has been toggled.
Check out this little video that shows the behavior.

Do y’all think this is intended behavior?

If not I’ll see what I can do in terms of whipping up a patch to fix it :wink:

1 Like