Diffuse translucency way too difficult to set up in Cycles

We should indeed have better builtin support for this. Thin surface support for the Principled BSDF is on the roadmap.


Good to know that, thanks!

I know that the scope of Code Quest is not large enough, but any chance of this making it into 2.8? I mean, I can do it myself using the trick above, but I would like Cycles to work well out of the box for everyone, without a need to have deep understanding of rendering. I am a bit worried about what kinds of obscure ways people use to create thin translucent materials these days :slight_smile:

It’s quite possible this will be in 2.8 since the final release is quite a while away, but there’s no guarantees. Cycles development continues mostly independent of the code quest or 2.8 planning.

1 Like

Any updates if this is going to happen? I’m currently building a foliage collection for my professional archviz purposes and remembered that there might be changes to how thin translucency is rendered.

I just hope this “fix” will be done in such a way that old hacky foliage shaders won’t break. :slight_smile:

No news on this at the moment.

Up. Getting close to 2.8 release… Thin translucency going to make it or not?

I’m curious, when mixing translucency for foliage (like a leaf, or grass) is there any correct value to put into the mix fac? Or is it just subjective? Without it properly integrated into the Principled BSDF node as you inch closer to 1 you lose all the physical properties of the Principled shading. I just can’t find a physically accurate way to mix translucency into my shader setups. For a long time I though using an Add node was the way to do this, but as I have read this too is innacurate.

1 Like

Bumping this thread again. It’s really important to solve the odd fresnel behavior in both Eevee and Cycles because pretty much no one knows about this corner case yet almost everyone breaks their teeth on it.

CGCookie has released a recent video about Glass Materials in Eevee, and check this timemark:

I mean, if even CGCookie, one of the largest Blender tutorial creators does not know about the ugly workaround one has to do to actually make Fresnel node behave correctly:

…then how can you expect average user to?


That’s not correct for thick glass. This workaround is only for thin glass. 2D geometry or bubbles.
What it needs is a thin optics checkbox.
In the video, these models have volume, so using Fresnel straight out of the gate is technically correct.

That being said this isn’t the only issue with it. It also ought to have a roughness input which requires a different overly complicated workaround to achieve.

Hi,can you expand the above node group to include specular and normal map ,add all the map input in Principle shader would be best ~

I also have problem with Translucent, it affect my diffuse that turned to the Sun…
with Principled only shader

with Translucent 50/50

See difference? It add translucent for behind of the Sun but lower diffuse level.
How to handle this situation?, I want diffuse not to change, and behind the Sun my petals were translucent.

I only could fake it with boosting value with Hue node…

You can revert to regular Principled BSDF based on the side (normal) of your mesh, as in here:

Another method i used in the past is to not worry about physical correctness and use the add method, dimming the translucency as much as it looks good:

But that’s physically incorrect and won’t work when the direct light will hit a backface.

Which one of the two ?
(oh, actually both are incorrect I know)

And with backface it only work for mesh that have face turned to sun and backface is opposite, but if backface is turned to the sun and face is opposite it have incorrect calculation (hope you understood me).

So for now fakes with diffuse value works the best for me…

I do. So you have a lot of sunflowers and their orientation may vary, right?
Give the second setup a test. Again I know it’s not correct, but sometimes it gets the job done.

1 Like

Tried second setup.

it lighten diffuse shader and it need to correct with hue node =)
my God, how this is hard to setup…

I think Translucent need some rework.
I thought I did something wrong, but now I see that is something odd with Translucent.

Thanks for helping!

But that’s physically correct behaviour due to the conservation of energy. If 50% of light gets scattered through the back of the surface, that means that only 50% is reflected, and that’s why the front side appears darker. So there’s nothing wrong with translucency in this case.

I guessed about it. But still hard to achieve real looking.
I think the main problem that in real life we have no surface with 0 thickness, thats why Translucent behave like this in my case.

The best option for me it’s if Translucent shader had some kind of compensation (zero thickness compensation) option for original diffuse.
Because first you setting up Principled/Diffuse shader, and then add Translucent to it, which change your diffuse setup and you need tweak it after.

I don’t think it’s a good solution to add physics-breaking options to shaders. Proper approach is to set up your material with translucency from the start and then adjust light, exposure and textures to get the desired result.