Cycles-X feedback

I’ve just downloaded cycles X the other day and its amazingly fast. The main problem I have at the moment in that of storage. I’ve noticed blender has gone up to 5 or 6 gb and as a person with not very good storage its not the best. Ionly noticed this though when I was unusually low in storage which flagged the mac “your system has run out of storage” window so this might be normal. Another thing is that final render doesn’t work and only just shows transparency. I’m pretty sure this is a bug so i’ve filed in a bug report. Also when ever I render it does not update any change in samples, I have to save and close to update. Overall I am really excited for cycles x as I use Cycles a lot as Eevee can get quite laggy at times.

I’ve just made a new Cycles-X build, after it was updated by Brecht and Sergey on April 28th. It can be downloaded from the Experimental Branches page.

2 Likes

I’ve encountered a strange bug in one of my scenes in the new version (43789b764d9a). When I switch to the rendered mode or when I try to render something, I get this error: Failed to create CUDA context (Illegal address). Sometimes it produces this line of errors:

I’ve seen this bug in the previous version as well (1dea1d93d39a), but only when I tried editing meshes in the rendered mode. But this time I can’t even switch to it. The scene crashes even if I switch to the CPU mode.

I tried some of my other scenes and they work fine.

Windows 10 x64 (2004 19041.867)
GTX1660 (466.11)

Because I’m a new user I can’t att. the crash log or copy the text here because it’s too big.

UPDATE: Found the problem - Emissive material (Principled BSDF) with alpha breaks the renderer. The breaking happens when you either connect texture Color to the Base color slot of the shader or the texture Color to the Emission slot of the shader . Here is the picture of shader that breaks the renderer:

1 Like

Since Multi GPU is on the roadmap, I’m going to argue this is not a feature request, but
is there any chance @brecht @sergey know about / could take some inspiration from
this paper:

https://dl.acm.org/doi/10.1145/3447807

Its a fork of cycles optimised to work across up to 16 GPUs and on scenes of 120Gb
in size or more.

3 Likes

One of the authors of the paper has already dropped a note, which was then generally acknowledged by Brecht, over at blender.chat the other day.

2 Likes

Done quick benchmarks on CPU with 3 production files of my own, and recent Sinosauropteryx splashcreen.
In every case Cycles-X is 8-10% slower. The performance regression is clearly seen with consistent CPU underutilisation oscillating between 85-100% througout whole rendering time.

Tested with Threadripper 3970x and Linux 5.10.0-6.
All files are checked for volumes and other known non-Cycles-X compatible objects and functions.

I am seeing a significant slow down for Cycles X comparing with the master as well. Glad to see somebody having the same issue, it is strange because most of the people reported Cycles X to be faster, strange.
Here is the comparison:


I have done several testings ever since its annoucement, and Cycles X has been consistently slower than the master, no matter I use CPU GPU CUDA OPTIX etc, Cycles X would always be slower.

Note that for fairness we should not use the openimage checkbox in the render tab, rather we should use the denoise node. Because in master the speed of the openimage check box is influenced by your tile size setting. And because Cycles X canceled the settings of tile size, you cannot control this variable. So please do not use OpenImage in the render tab when testing, if your use it, you would see a false speedup and you are tricked.
image

Because it should be removed, nobody should even use it anymore, look at this:


This has always been the case for me ever since 2.78 (or 79?) or so when it just came in, I am never a fan of it. That’s why the AI denoiser was such a big news at 2.81

Do you have multiple GPUs by any chance ?

no, I have only one GPU

would you mind providing that scene with the strange slowdown ?

It happens to pretty much every scene I have, but I can provide the file of the above images

yes please, the idea is to double check on other ppl hardware and see if there is a certain setting responsible for the slowdown.

The file needs to be opened with 3.0. And I have the auto tile size addon enabled for the master (also for the x, but it should have no effect on x)

Just opened the file on both 3.0 master (latest build available) and cycles X branch (latest build available), and activated auto tile size add-on and pressed F12.

My Cycles X is faster then master (00:09.78 vs 00:14.99) with Master peaking at 16.12M VRAM while Cycles X peaking at 596.94M VRAM usage.

on your two screenshots both renders are peaking at a pretty low memory usage of ~ 9M VRAM, it’s as if cycles X is not working it’s magic (of eating more VRAM vs speeding things up). (which I hope can be brought down to more acceptable peak value down the line).

1 Like

Strange, your Cycles X is faster, but mine is slower

About the RAM, I have also tried rendering right after restarting my computer (don’t know whether it is related), didn’t help

EDIT: In fact I asked some of my friends for their test results, I got inconsistent answers. Some say Cycles X is super fast, some say a few seconds slower than master, some says about the same, some says faster but just a few seconds, and I am like the only one having Cycles X being very slow. This is very strange.

There must be something off with your system preventing Cycles X from working properly, maybe try updating Nvidia drivers, and check if some process/app is preventing blender from eating more resources, monitor your GPU VRAM usage while rendering.

Btw i’m on Linux using GTX 1050Ti with 460.73 Driver.

I am on Windows 10 version 20H2, Nvidia driver version 466.27, anti-virus software set to “gaming” mode

EDIT: Please just ignore this post, sorry

I think I just found the reason for the slow down. To my surprise, it seems to be the auto tile size addon. I thought it woud have no effect on Cycles X so I left it on, but it looks like it is dragging it down:


I cannot believe how huge the different is, why would auto tile size have anything to do in Cycles X?

EDIT: Wait, I cannot reproduce it anymore, I swear it was the case… Let me play with this a bit more
EDIT Again: I think one thing I can still consistently reproduce is that it gets faster if I load factory settings
EDIT 3: Nevermind, the speedup I was seeing after loading factory settings, was pobably just the device being set to the default none, and therefore I was using CPU. I did notice that on Cycles X CPU seems faster than GPU, but compare with master, CPU on master is still faster