Cycles doesn't show up in master build

I can’t find the cycles renderer in the render dropdown on my latest master build (it’s up to date, I did a git pull today and git status shows up-to-date too). It’s a VS 2019 project, debug build, if that helps. I double checked that the cycles addon is enabled, I loaded the factory settings, I forced a complete rebuild, nothing helps. The cycles projects in VS get built. I made two screenshots:

Have you any idea what could cause that? I really have no idea.

did you build the INSTALL project?

Now that’s strange. Thanks for the info, building INSTALL fixed the problem, but why? I did it before, for this exact project configuration!

Cycles relies on a handful of .py files to be in the add-ons directory, which is what the INSTALL step takes care of. When those files are missing or out of date, Blender cannot initialize Cycles.

Pardon me sir, but I’m attempting to learn the ins and outs of building Blender from source today; and I’ve gotten everything working other than this. It sounds like you know what’s wrong, but I have no idea what the “INSTALL project” is, and can’t find any useful references to that word in the documentation. Is it a make flag of some kind?

If you have a moment, could you direct me to where I can learn more about this? I’m glad that @BenjaminMuller has a solution, but I’m still in the dark. Thank you!

INSTALL target * is the term for non-visual studio generators I guess [1] [2]. It’s one of the dozens of targets printed after make help or ninja help in the build folder, for example bf_intern_cycles.

From Lack of consistent MD5SUM checks on boost library assuming you’re using make generator, run make install in the build folder.


I actually am on Linux, specifically Mint 19. I’m quite familiar with make targets. Anyway, I’m presuming the compiler is GC++ and the linker is ld; but make install just tells me that install isn’t defined as a target. It isn’t in the GNUmakefile, so this is no surprise, but I figured I’d give it a shot. For that matter, bf_intern_cycles also isn’t in there or in make help, which also doesn’t really surprise me as these are just targets, they have to be defined.

I appreciate your notice, but make install also had nothing to do with the other error, I had a corrupted file and git push origin master solved it for me. It’s already resolved, I’m just not closing the topic until I have a fully functional build.

Do you know what the “INSTALL project” is, or can you point me to documentation? Or is this just a friendly speculation?

You’re running it in source code folder, not in the build folder as mentioned earlier.

I’m not on windows, so I cannot be sure. From what I see in docs, make “targets” are “projects” in visual studio. In Xcode (macOS), they’re “schemes” apparently.


Also, see the section “Utility Targets produced” on

Good to hear that the other method solved the issue for you.

The “install” target is used to copy the needed user interface python files and other things into the place where the executable expects to find them. I use the ninja builder on Linux, and do “ninja install” in the build directory when I want to make sure the latest UI etc. is installed.

Under what circumstances does make generate a Blender without installing? (When running it from the git repo):

~/blender-git/blender $: make update
~/blender-git/blender $: make ninja

Always installs for me. I’ve only ever had the “not installed” thing after running the rebuild script in build _linux.