Cycles AMD HIP device feedback

I also just noticed that everyone who reported at least limited success uses an RDNA2 card, while Luciddream and I both have crashes and we both use 5700XTs.

Filed a bug report: ⚓ T97591 Address boundary error rendering with HIP on Linux, maybe RDNA1 specific


I’m pretty sure my 6800xt is running at 2560mhz core frequency and 2120mhz memory,I looked up the online benchmarks, 6800xt in 3.0 is 63s, my 3.1.2 is 97s, it seems to have become slower (wait for the time to re-download the standard project) but compared to 40s linux system still has nearly 50 percent performance improvement.Of course I don’t know how many iterations were used for the review rendering
Blender-3.0.0-Cycles-GPU-Render-Performance-Classroom-680x3836800xt rendering slower than expected at 63s - YouTube

I think the review may have used a much smaller number of iterations I remember 2.93 was 150. I used 3.2 alpha rendering once and it took 2 minutes, slower than 3.1.2

With the Techgage 3.0 review they changed the render resolution of classroom to 2560×1440 and tile size to 256×256, I assume they used 300 samples (I got 77 sec when rendering to the Techgage spec for classroom).

Do you know how your Blender benchmark “score” as opposed to classroom render time. You should get a 2000+ “score” for a 6800XT on Windows, Linux or Mac.

Why is my hip not as fast as opencl? 2.93.9 version 1920x1080 one-time rendering only takes 1min 17s

(As for the gamma problem I found that when there is a master version zip version of certain scenes will appear biased white)

Changed a 21.q4 driver 36s on the rendering is complete, it really is a driver problem.

The previous driver version was 22.4.1

1 Like

I’d like to try the distribution of linux that you are using,Only OS - 5.17.1-arch1-1 I do not know which system is used

I am using Arch Linux, I think its fairly popular, however…

  • Linux and Windows when properly configured have similar performance in Blender.
  • Blender don’t specifically package for Arch but its in the official repo within a few days and the nightlies work
  • AMD don’t package for Arch, however the community has a handy package called opencl-amd that supplies the “HIP bits”
Linux Stuff
  • Arch is not a great as a first go at Linux, Ubuntu is much better at that.
  • Arch looks horrible when first installed, needs lots of tweaks and fonts
  • Arch is rolling release so its bleeding edge but lots of things break.
  • You need to specify what display manager you want, I chose XFCE.
  • If you still want to try it I strongly recommend using Archinstall.
  • On the Pro’s Arch’s wiki is concise and detailed.


1 Like

Hi there. Are the summary of users having issues based on 5X00 series cards? ⚓ T97591 Address boundary error rendering with HIP on Linux, maybe RDNA1 specific
This issue from @wsippel ? 6X00 seems ok?

Just to recap you need the ROCM 5.1 driver or the upcoming closed source driver based off it and the latest blender build.

Yes I’m also having the same error and have a 5700XT. (build 179100c02126). I now have a new CPU (5900x) and can tests patches / builds more easily, in case you want us to try something.

My 6800 works on Linux ok as per my post above, however I am not using a configuration that AMD supports.

After a bit of use only issues have been:

  • Random GPU crashes, however this may be related to a longstanding issue with AMD on Linux not specific to Blender, hopefully it can be fixed.
  • Using a 16k world background renders on CPU, but HIP GPU gives the following error
Invalid value in hipTexObjectCreate(&cmem->texobject, &resDesc, &texDesc, __null) (intern/cycles/device/hip/device_impl.cpp:1083)

To clarify, when you say “driver”, are you referring to the kernel driver itself? If so, I’m pretty sure neither ROCm package on Arch installs the closed source kernel driver. There is a package for the DKMS driver (amdgpu-pro-installer), but I’d prefer not to mess with that if at all avoidable, so it would be very much appreciated if you could specify.

I also just tested again, with ROCm 5.1.1, the latest Blender nightly, and kernel 5.17.5 (which admittedly had no amdkfd fixes over 5.17.4 IIRC), still crashes in hipTexObjectCreate.

@bsavery just wondering if there has been any movement on HIP-RT for cycles… totally understand if there is nothing you can talk about right now!

1 Like
1 Like

I remember vega no rt, rdna2 began to have rt

How to forcibly turn on hip support for GPUs that are not in the list support range, such as radeon rx680m of rdna2 mobile platform? Is there anything like Environment variables such as CYCLES_ HIP_ SPLIT_ KERNEL_ TEST=1?

The main way of using AMD GPUs that are supported by the Cycles HIP implementation (E.G RDNA2 Mobile) but not supported with the pre-compiled kernels found in the release build of Blender is to compile Blender from the source code yourself with that specific device enabled.
You can find a guide on how to build Blender here: Building Blender - Blender Developer Wiki

However, along side that you also need the HIP SDK. I don’t believe the HIP SDK is publicly available on Windows, and as such you may not be able to use this approach on Windows unless the HIP SDK is make available (I may be wrong about this part).
The HIP SDK is publicly available on Linux if you’re using that.

Sadly, at the moment there are no documentation I can find that details how to configure the Blender build with the HIP SDK. So you may need to seek advice from others or figure it out yourself.

I’m sorry if this isn’t particularly useful.


I’m currently on blender 3.1 and I noticed that rendering on my RX 6700 XT GPU was extremely slow. It was something like 5 or 6 times slower than expected based on benchmarks on the internet. I tried turning off SAM (smart access memory/resizable BAR) and it seems to have resolved the issue.

CPU: AMD Ryzen 5 3600
RAM: 2133 Mhz (slow because of compatibility issues between the modules and the Ryzen platform but stable and consistent)
GPU Driver Version: AMD-Software-Adrenalin-Edition

I’m not sure what other information to include so here are my observed rendering times:
To test, I rendered ‘Classroom’ at 150 samples 4 times using different device settings.

Render 1
Device: GPU Compute (HIP)
SAM/Resizable BAR - OFF
Rendering time: 32.59 seconds

Render 2
Device: GPU Compute (HIP)
SAM/Resizable BAR - ON
Rendering time: 2 minutes 46.93 seconds (412.2% slower than SAM OFF)

Render 3
Device: CPU
SAM/Resizable BAR - OFF
Rendering time: 4 minutes 57.93 seconds

Render 4
Device: CPU
SAM/Resizable BAR - ON
Rendering time: 5 minutes 3.05 seconds (1.7% slower than SAM OFF, probably mostly due to stock cooler)

Sorry if the information provided is insufficient or pedantic I just never know what to include.
I may also note that in other applications SAM doesn’t have this big of an effect on performance on my specific hardware. Usually, the difference is within a few percentage points, if that, from what I’ve seen.

1 Like

Tested again with ROCm 5.1.2 and 5700XT, getting the same error.

:3:hip_texture.cpp          :1453: 9415878854 us: 48646: [tid:0x7f43ddfff640] hipTexObjectCreate ( 0x7f4,2a8,172,9e8, 0x7f4,3dd,fb9,140, 0x7f4,3dd,fb9,0d0, char array:<null> )
:4:rocdevice.cpp            :2034: 9415879067 us: 48646: [tid:0x7f43ddfff640] Allocate hsa device memory 0x7f41d9e00000, size 0x169000
:3:rocdevice.cpp            :2073: 9415879071 us: 48646: [tid:0x7f43ddfff640] device=0x7f43ceaef800, freeMem_ = 0xfa142710
:4:rocdevice.cpp            :1899: 9415879196 us: 48646: [tid:0x7f43ddfff640] Allocate hsa host memory 0x7f43e7de8000, size 0x110
Writing: /tmp/classroom.crash.txt
fish: Job 1, 'AMD_SERIALIZE_KERNEL=3 AMD_SERI…' terminated by signal SIGSEGV (Address boundary error)

./blender' terminated by signal SIGSEGV (Address boundary error)

classroom.crash.txt (2.4 KB)